[SOLVED] OH2 myopenhab-client seems to disconnect after some time

  • Platform information:
    • Hardware: RPi3+
    • OS: Openhabian current version
    • openHAB version: 2.1
  • Issue of the topic:
    Hi everyone.

I have lately experienced two events for which I cannot nail anything down in the log:

I have my OH2 hooked up with Alexa and the Hue Service, both worked fine for weeks

  1. Last Thursday my system went offline within myopenhab, without anything specific in the log besides the fact that it tried to connect, succeeded and the disconnected immediately. This happened continuously. A reboot fixed everything then.

  2. Now today Alexa told me that the specific item did not respond when trying to access OH2 based functions. The Hue connect meanwhile worked fine. This time the system was shown as online in myopenhab (!), so no messages about disconnects in the log. A reboot of the pi fixed it again. Still no clue what’s going on here.

So does anyone have an idea where to start over for further debugging?

Thanks a lot


This unfortunately has been going on for awhile.

Hopefully @digitaldan will be able to shed some light on this.

Hi KidSquid,

thanks for your reply, but I am not sure what the Hue problems have to do with my OH2 not responding? As I wrote, the (direct) Hue Connection to Alexa (or more precisely, the Hue skill within Alexa) does work without problems.
It is OH2 itself that behaves erratically by either not responding to Alexa or going offline for no apparent reason (additionally, I am still on OH 2.1…)

Have a great week

Edit: I guess I understand now where you are coming from. I am using the Hue Binding to control the Hue Bulbs by OH2, as well as the Hue Skill on Alexa for direct control of the bulbs, not the Hue Emulation. OH2 is connected to Alexa using the native Alexa Skill via Myopenhab. Maybe we had some missunderstanding here :wink:

Hi there,

today the problem was seen again. Alexa was already taking some time, before commands on OH2 where executed. Now this afternoon, I am once again back to “XYZ is not responding”.
The OH2 log shows

“2017-12-16 09:01:14.305 [WARN ] [io.openhabcloud.internal.CloudClient] - Jetty request 6876791 failed: null”

And once again the connect-disconnect game starts:

2017-12-20 18:17:41.599 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = (uuid), base URL = http://localhost:8080)
2017-12-20 18:17:56.290 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = (uuid), base URL = http://localhost:8080)
2017-12-20 18:18:31.209 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: io.socket.engineio.client.EngineIOException: xhr post error
2017-12-20 18:18:31.220 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = (uuid), base URL = http://localhost:8080)

(uuid represents my system id, which has been removed for security reasons here)
Maybe there is a problem with the cloud client?

The cloud service must’ve blipped – I have identical errors at the exact same time. I got disconnected about 18:16 GMT and reconnected a few minutes later, at 18:19 GMT.

Thanks, interesting to know. Although, after the connect-disconnect games starts, it does not get back to normal without a reboot.

Hm. Anyone else an idea?

Actually, my logs say it reconnected 3 minutes later, but myopenhab says its disconnected. So there is an issue there, too. A restart “really” reconnected.

As some people seem to have intermittant connection issues with myopenhab.org, I’d assume that the problem might be caused by the server side. Somebody stated in annother post, that the two maintainers of myopenhab have only very little time, so not sure if anyone just has the knowledge and the time to see if there are problems on the server side…

Let’s see how this develops…

There was definitely a server drop-out. Those happen, though. The bigger concern is the connection not re-opening properly.


Haven’t seen this behaviour lately. Maybe it was the server, maybe the 2.2 did some magic.
Whatever :slight_smile:

Not sure why this is marked as Solved. The issue is still there. For me the cloud service went off-line and the only thing that would bring it back on-line was a Pi reboot. Prior to this tried stopping and starting the Cloud Binding in the Console and then uninstalling and re-installing the openHAB cloud service in PaperUI. Only the reboot fixed the problem.
Running tmpfs so lost the event log on the reboot - sorry.

You are correct, the issue is intermittendly back here as well. There are days with a ton of disconnects, and others with no problem at all.

No idea what to do against it

Same here… :frowning: