[SOLVED] OH2 not loading sitemap from (/etc/openhab2/sitemaps)

Hi
Until recent I had a well working sitemap in (/etc/openhab2/sitemaps) but after fildeling around in Habmin another sitamap called Home (_default) is Loading only showing things.
Where is this sitemap located?
How do I make it load the sitemap in (/etc/openhab2/sitemaps)?

/Liltorp

1 Like

The _default sitemap (titled `Home) is “embedded” in OH2. It is stored somewhere internally (never checked where exactly it is :slight_smile:). I also have it in my system.

HABmin should load also whatever *.sitemap file you have stored in your /etc/openhab2/sitemaps directory and show it together with the _default one.

Does your new sitemap work properly in other UIs? (like Classic or Basic)?

It’s automatically created, there is no file for that. And it has nothing to do with HABmin :slight_smile:

Go to PaperUI->Configuration->Services->UI->click “Configure” on the UI you are using and place the name of your sitemap you wish to load at “Default Sitemap”

or

just add the sitemap name to the url:

http://<your_server_ip>:8080/basicui/app?sitemap=yoursitemapname

2 Likes

@Dim too fast for me :grinning:

1 Like

Wow you guys are fast…basic, classic and the app only shows _default, the one in (/etc/openhab2/sitemaps) is not shown at all.

When I put in

kildevang1 is the sitemap placed in /etc/openhab2/sitemaps

Post the contents of the sitemap file to check it

Here the sitemap:

sitemap kildevang label=“Kildevangen 72”
{
Frame {
Group label=“First Floor” icon=“firstfloor” {
Slider item=Sovevaerlse label=“Soveværelse” icon=“bedroom” switchSupport
Slider item=Bad label=“Bad” icon=“bath” switchSupport
Slider item=Spisestue label=“Spisestue” icon=“sofa” switchSupport
Switch item=Koekken label=“Køkken” mappings=[ON=“On”, OFF=“Off”]
Slider item=TvStue label=“Tvstue” switchSupport
Switch item=Trappe mappings=[ON=“on”, OFF=“Off”]
}
Group label=“Ground Floor” icon=“groundfloor” {
Text label=“Gildesal” icon=“groundfloor” {
Frame label=“Gilde Stor” {
Slider item=Gilde switchSupport
}
Frame label=“Gilde Lille” {
Slider item=Bar switchSupport
}
}
}
Group label=“Udendørs” icon=“garden” {
Text label=“Svalegang” icon=“firstfloor” {
Frame label=“Udhæng” {
Slider item=Svalegang switchSupport
}
}
}
Chart item=Niveau_sovevaerlse label=“Sove [%s r]” icon=“light” period=10service
}
Group item=All label=“Alt”
}

A Group element needs an item to be used

This is not working:

Group label="First Floor" icon="firstfloor" {

from ESHD:

If you want just a grouping of your sitemap stuff within a Frame, use a Text element

Text label="First Floor" icon="firstfloor" {

Edit:

By the way, make sure that the <filename>.sitemap is the same as the <sitemap_name> within the file.

Example:

sitemap kildevang label="Kildevangen 72"

should be stored in the file: /etc/openhab2/sitemaps/kildevang.sitemap
Don’t use any special characters for the <filename> and/or the <sitemap_name>

1 Like

Thank you very much for your help. Now it is working again :slight_smile:

1 Like

I know this is an old thread, but I am just starting with OH, and discovered this issue.
Thanks to the advice here, I have everything but Paper UI loading the right sitemap. Is there a way to do this for Paper UI? Also does the “Other” at the top of the Paper UI mean anything? Is it related at all the sitemap?

No, PaperUI does not render sitemaps. Only BasicUI (and ClassicUI and HABmin). Most use BasicUI.

It is not related to sitemaps. It is related to the Location of a Thing. You can configure this parameter in PaperUI for each Thing and you can see in the control tab of PaperUI your related Items (the ones that are linked to the Thing with such Location).

If you have not assigned a Location to your Things, the associated Items will appear under the Other Tab in the Control section of PaperUI.

Important Note: The above story is true only for Items linked to Things (v2 bindings)… not Items linked to legacy (1.x) bindings. You won’t be able to see in the Control section any v1 bound Items.

See for example: Migration to KNX2 with multiple bridge

1 Like

Ah! That makes sense now. Thank you for helping me understand.

1 Like