[Solved] OH2: PaperUI channel cannot unlink item

Version: 2.5.9 (Build)
System: Host: rpi3ohv2 Kernel: 5.4.51-v7+ armv7l bits: 32 Console: tty 2 Distro: Raspbian GNU/Linux 10 (buster)

I got an error:

2020-10-22 13:52:05.931 [ERROR] [ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item for widget org.eclipse.smarthome.model.sitemap.sitemap.Text
2020-10-22 13:52:05.934 [ERROR] [ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'PumpStation1_SoilMoisture' for widget org.eclip

… which stems from a wrongly linked item to a channel.

I tried to unlink the item from a channel in PaperUI; as the textural config in .things and .items is correct(ed).
However, PaperUI errors with Error 405 Method not allowed… and insits on keeping the linkage.

image

items

Number   PumpStation1_Moisture              "Moisture 1 level [%d]"                                         (gPumpStation1_Moisture_Chart)    {channel="mqtt:topic:mymosquitto:pumpstation1:soilmoisture"}
Switch   PumpStation1_SoilPermittivity      "Stn 1 soil permittivity"                                       (gIrri1All)                         {channel="mqtt:topic:mymosquitto:pumpstation1:command"}

things

Bridge mqtt:broker:mymosquitto [ host="localhost", secure=false, port=1883, clientID="openhab2" ]
{
    Thing topic pumpstation1 "Pump Station 1" @ "Irrigation Tank"
    {
        Channels:
...
            Type number : soilmoisture "SoilMoisture" [
                stateTopic="ArgyleCourt/Property/PumpStation1/SoilMoisture"
            ]
...
            Type string : command "Command" [
                stateTopic="ArgyleCourt/Property/PumpStation1/Command",
                commandTopic="ArgyleCourt/Property/PumpStation1/Command"
            ]
    }
}

Trying to unlink via karaf also unsuccessful:

openhab> smarthome:links list | grep -i soil
PumpStation1_Moisture -> mqtt:topic:mymosquitto:pumpstation1:soilmoisture
PumpStation1_SoilPermittivity -> mqtt:topic:mymosquitto:pumpstation1:command
PumpStation1_SoilPermittivity -> mqtt:topic:mymosquitto:pumpstation1:soilmoisture
openhab> smarthome:links removeChannelLink PumpStation1_SoilPermittivity mqtt:topic:mymosquitto:pumpstation1:soilmoisture
Could not remove link PumpStation1_SoilPermittivity -> mqtt:topic:mymosquitto:pumpstation1:soilmoisture.
openhab>                                                                                                                                                                                        

How can I get rid of that linkage?

Dose the problem persist after reboot or restart?

A fair question, and from what I read on the forum, a restart got rid of it.
But…
I do not want to use a system where I have to restart it, in order to make standard changes. That is simply an immature system.

I restarted OH, and the link no longer exists… still :yawning_face:

The standard actions would be to delete a PaperUI created link via PaperUI and to delete a .items file created link via this file.
Mixing them up is what is causing the problems. Do or did you have the Simple Mode set to ON?

Thanks for the explanation… :slight_smile:
It would be unreasonable for me to claim I did not make a mistake. (I was changing lots of mqtt items and created things for them.)
However, I believe I applied the same logic as you did.
I created the broker via UI, and two things.
I deleted the two things and then the broker.

What this confirms though is, I will create whatever I can via config files, rather than in something I cannot see or fix.