[Solved] OH3: Creating channels in mqtt thing not possible

Hi all,

just tried to create a mqtt generic thing. That works well and the new ui is nice for that. But if i try to add a new channel i have a very simple problem. Is is possoble to create the channel. Than i click on done and the list of channels ist displayed, but i i lease the thing display and come back later to see my channels, al the channels are gone.

So the ui oder the binding does not save the channel definition.

Has anyone alse this problem?


same problem here with error in log

2020-09-25 20:40:07.909 [ERROR] [ternal.handler.SimaticGenericHandler] - {} - command: RefreshType not implemented
1 Like

I guess You posted to the wrong topic.

I have created channels for my two MQTT devices via UI without any issue. Will check later what the important steps are.

I am on build #1943

Confirmed, that’s a recent bug.

@YSC Thanks for the info. Then i have to wait until it is fixed :slight_smile:

Fixed with this, I’ll merge it when the checks are green: https://github.com/openhab/openhab-webui/pull/358

You can temporarily upgrade to this version with:

bundle:update org.openhab.ui https://ci.openhab.org/job/PR-openHAB-WebUI/60/artifact/bundles/org.openhab.ui/target/org.openhab.ui-3.0.0-SNAPSHOT.jar

and hard refresh the page, if you don’t want to wait for a new distribution.
It will only last until you restart openHAB.


In build #1944 it is working again.


@YSC i found the next thing with mqtt. I created a generic item and forgot to select the bridge. If iopen the thing, than going to config an try to select the brindge. The window is closed immediately after selecting the bridge and i am back in the list of things. The bridge is not selected. Working now on build #1945

It happens sometimes, the router becomes confused and going back goes back twice, I don’t know why. Probably should investigate harder. Normally refreshing the page makes the problem go away.

1 Like

@YSC: Yes that solved the problem