[SOLVED] OH3: zWave Aeotec Z-Stick Gen5 cannot be initialized

Tags: #<Tag:0x00007efed23c9c68>

Hi

I’m moving my OH environment to a new server (old server was on CentOS7 and OH2) and have done a fresh installation.
But I’m getting issues with my zWave stick.
I added it a thing in the GUI (same configuration as on the old server).
But the thing remains offline -> BRIDGE_OFFLINE - Controller is offline
Details below. Hope someone can push me in the right direction.

  • Platform information:
    • Hardware: Intel® Pentium® Silver J5005 CPU @ 2.8GHz
    • OS: CentOS Linux release 8.2.2004 (Core)
    • Java Runtime Environment: openjdk version “11.0.9” 2020-10-20 LTS
    • openHAB version: openHAB 3.0.0.M2

openhab.log

2020-11-11 19:45:33.475 [INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null

configured /etc/default/openhab

EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB-ZStick:/dev/ttyACM0"

I have also added the required groups and softlink

[root@homeserver openhab]# ll /dev | egrep 'USB|ACM'
crw-rw----. 1 root dialout 166,     0 Nov 11 19:20 ttyACM0
lrwxrwxrwx. 1 root root            12 Nov 11 19:26 ttyUSB-ZStick -> /dev/ttyACM0

[root@homeserver openhab]# cat /etc/group | grep openhab
tty:x:5:openhab
dialout:x:18:openhab
audio:x:63:openhab
openhab:x:981:

New hardware and OS… ports are probably different on the new server

1 Like

@5iver you are wrong. If you had read my post then you could see it‘s still /dev/ttyACM0.
I remember now whats missing:


I will check that tomorrow

Edit 13.11.2020: zWave sticck works in OH2 but not in OH3 on the same server, will open a new post.

I trying to help you out and point to what was likely causing your issue. I had read your post and nowhere did you state that the ports had not changed, but you’ve now edited your post with those details. Obviously, it was a waste of my time trying to help you.

1 Like

This part including the output was in the initial post (before editing) :shushing_face:
[root@homeserver openhab]# ll /dev | egrep 'USB|ACM'

That does not say the stick was on that port. Something like the output of dmesg from the OS would indicate that.

It does not exactly say, correct. But it is obviously.

The point made by the volunteers @5iverand I is that, from the content of your post it was not obvious. Many times the IS has devices listed in /dev that may or may not exist. We have both worked with Linux and UNIX systems for many years.

Arguing with volunteer experts is not a good way to get assistance here.

thats what he said and this is not true.

You have also made untrue statements

As a volunteer I am leaving this thread.

This is a statement without a proof.

I can live with that.

[quote=“HaKuNa, post:11, topic:108086”]
This is a statement without a proof.

[quote]

As proof I have been certified as a Solaris UNIX administrator and have been paid to administer UNIX and Linux systems for many years. What are your Linux expertise credentials??

off topic