[SOLVED] On every start: Internal error Source: openHAB (Extension)


(Semperor) #1

Hey there.
I get the same error, every time I start VS Code. And I think the file error check isn’t working.

Nothing more. I don’t find any further details.

  • VS Code 1.30.2
  • openHAB extension 0.4.1 - 2018-12-09
  • No other extensions
  • I only changed the openhab.host to my pi’s host name

Anyone any ideas?


(Jerome Luckenbach) #2

Internal error could be anything.
Lets see if we can reproduce it somehow, but for now i have got no idea.


(Semperor) #3

Found it. I used a saved workspace with that configuration:

{
	"folders": [
		{
			"path": "openhab2-conf"
		}
	],
	"settings": {
		"openhab.host": "deimudda"
	}
}

For reasons I haven’t used a connected network drive recently. I made a “quick connection” using //deimudda. It seems that VS code can’t handle that.

Solution: Always connect the openHAB server (Linux) as a network drive from Windows.


(Jerome Luckenbach) #4

Thanks for giving us feedback.