[SOLVED] OpenHAB 2.3.0-1 Stable: No FireMotD ExportFile detected

firemotd
openhab23
Tags: #<Tag:0x00007f51db2a7d60> #<Tag:0x00007f51db2a7c20>

(Ray) #15

After a clean install…


even tryed that workaround.


(Michael Bormann) #16

Hello Ray,

sadly I am unable to open the picture.

Would you please try to share it again?

Michael


(Ray) #17


(Ray) #18

Hi Michael,

That’s kind of weird! because I can see it without any issue.

But it shows:

2018-09-18 15:14:53,993: FireMotD: Info: No FireMotD ExportFile detected. Please generate with “sudo .\FireMotD -S”

End this is a clean install of openhabian (openhabianpi-raspbian-201804031720-gitdba76f6-crc9e93c3eb.img.xz) on a Raspberry Pi.

I did everything that is writen in this topic but whatever I do it comes with:

sudo: ./FiremotD: command not found.

Ray.


(Michael Bormann) #19

Hi Ray,

my fault … my companies proxy server is blocking the picture uri :slight_smile:

Please try:

sudo FiremotD -S

For explanation:
sudo ./FiremotD tries to find the file FireMotD in the current directory ( = ./ )
sudo FireMotD is looking for the file in different directories (use “echo $PATH” for details)

by the way:
when installing openhabian a routine is installing among other things FireMotD.
A couple of weeks ago IMHO there was a failure in the current FireMotD release.

the actual release [v10.03.180723] fixed the problems. you can get it by:

sudo openhabian-config

Please choose “10 | Apply Improvements” and in the next screen “15 | FireMotD”.

This will pull the latest release and blast your problems away.

hth
Michael


(Ray) #20

Hi Michael,

Thanks for the friendly responce.

First I did:
[15:06:31] openhabian@Raindomain:~$ sudo FiremotD -S
[sudo] password for openhabian:
sudo: FiremotD: command not found

Then I did:
[15:06:59] openhabian@Raindomain:~$ sudo openhabian-config
10 | Apply Improvements
15 | FireMotD

And that gave me this:

$ git clone https://github.com/OutsideIT/FireMotD /opt/FireMotD
Cloning into ‘/opt/FireMotD’…
remote: Counting objects: 943, done.
remote: Compressing objects: 100% (76/76), done.
remote: Total 943 (delta 52), reused 33 (delta 16), pack-reused 851
Receiving objects: 100% (943/943), 15.43 MiB | 2.00 MiB/s, done.
Resolving deltas: 100% (525/525), done.

$ bash /opt/FireMotD/FireMotD -S
2018-09-19 15:09:09,709: FireMotD: Error: Template folder doesn’t exist. Upgrading from an older version? Please run make again or run the install function “FireMotD -I -v”.
OK
2018-09-19_15:09:15_CEST [openHABian] Checking for default openHABian username:password combination… OK
2018-09-19_15:09:15_CEST [openHABian] We hope you got what you came for! See you again soon :wink:

I guess, I did not get what I was looking for.

Ray.


(CM6.5 H102) #21

@Ad3D change directories and run sudo ./FireMotD -l -v like this:

cd /opt/FireMotD$ sudo ./FireMotD -I -v


[SOLVED] MQTT & influx, no datapoints in grafana
Http://openhabianpi:8080/start/index connection refused
(Ray) #22

Thanks H102
That did it.

cd /opt/FireMotD
sudo ./FireMotD -I -v


(Frank Van Cleef) #23

Thanks for that, Alein – worked great on my system, too!

Frank


(Simon#56) #25

this worked for me, thanks


(Thomas Dietrich) #26

Worked as well for me, thanks. #H102

TomDidi


(WJ) #27

Thanks for everybodies input.
It worked for me too, but still needed to redo some things before it was actually solved.
In the end think this was my sequence of relevant commands (cd~ really relevant?):

sudo mv /opt/FireMotD{,.old}
cd ~
wget https://github.com/OutsideIT/FireMotD/archive/v8.08.171007.zip
unzip v8.08.171007.zip
mkdir /opt/FireMotD
cp -pR FireMotD-8.08.171007/* /opt/FireMotD
cd ~
sudo bash /opt/FireMotD/FireMotD -S
sudo reboot now

Because the problem is solved now I hope all is correct :slight_smile:


[SOLVED] Get my PI into WIFI
(Michael Cumming) #28

work for me as well. thank you.


(Christoph Nagel) #29

Found this:

Tried it - it solved the problem!


[SOLVED] [FireMotD] Error: Template folder doesn't exist
(Metin) #30

Worked for me, too. Thanks!


(CR) #31

This one fixed specifically my issue. Thanks!


(rud) #32

Worked for me. Thank you!


(Felix) #33

H102 answer works also for me - but what is the cause for the problem?

If I get it right FireMotD is used to create the ‘sudo openhabian-config’-config dialog - is that correct?
And the FireMotD version used in openHAB 2.3.0-1 Stable has an bug resulting in the error message? Or is is the way how FireMotD is configured for openHabian that is causing the error?
And the fix mentioned in the error message is not working because of the way how FireMotD is configured in openHabian?

If the version is the cause - why is an manual update fixing the issue? Are we using an outdated version of FireMotD?

If the configuration of FireMotD for openHabian is the issue - why is the problem still existing in openHAB 2.4.0-1 (Release Build)?

So IMO the issue is not solved as long as an fresh installation of openHabian still shows the error message…

Additional question: Leaving the error message aside - is this issue causing any problems / any harm to the openHabian setup? Is anything not working correctly? Or is the error message the only problem with FireMotD?

(This post is not trying to blame anyone - I’m just trying to understand the issue)


(Torsten) #34

I second this - still happens with a fresh 2.4.0-1


(CM6.5 H102) #35

Nothing else is effected and if I’m not mistaken OH will run fine with or without FireMotD.

For the other questions about a fix have you checked to see if there’s an open issue on Github?