[SOLVED] OpenHAB 2.3.0-1 Stable: No FireMotD ExportFile detected

Thanks H102
That did it.

cd /opt/FireMotD
sudo ./FireMotD -I -v


Thanks for that, Alein – worked great on my system, too!


this worked for me, thanks

Worked as well for me, thanks. #H102


Thanks for everybodies input.
It worked for me too, but still needed to redo some things before it was actually solved.
In the end think this was my sequence of relevant commands (cd~ really relevant?):

sudo mv /opt/FireMotD{,.old}
cd ~
wget https://github.com/OutsideIT/FireMotD/archive/v8.08.171007.zip
unzip v8.08.171007.zip
mkdir /opt/FireMotD
cp -pR FireMotD-8.08.171007/* /opt/FireMotD
cd ~
sudo bash /opt/FireMotD/FireMotD -S
sudo reboot now

Because the problem is solved now I hope all is correct :slight_smile:

work for me as well. thank you.

Found this:

Tried it - it solved the problem!

1 Like

Worked for me, too. Thanks!

This one fixed specifically my issue. Thanks!

Worked for me. Thank you!

H102 answer works also for me - but what is the cause for the problem?

If I get it right FireMotD is used to create the ‘sudo openhabian-config’-config dialog - is that correct?
And the FireMotD version used in openHAB 2.3.0-1 Stable has an bug resulting in the error message? Or is is the way how FireMotD is configured for openHabian that is causing the error?
And the fix mentioned in the error message is not working because of the way how FireMotD is configured in openHabian?

If the version is the cause - why is an manual update fixing the issue? Are we using an outdated version of FireMotD?

If the configuration of FireMotD for openHabian is the issue - why is the problem still existing in openHAB 2.4.0-1 (Release Build)?

So IMO the issue is not solved as long as an fresh installation of openHabian still shows the error message…

Additional question: Leaving the error message aside - is this issue causing any problems / any harm to the openHabian setup? Is anything not working correctly? Or is the error message the only problem with FireMotD?

(This post is not trying to blame anyone - I’m just trying to understand the issue)


I second this - still happens with a fresh 2.4.0-1

Nothing else is effected and if I’m not mistaken OH will run fine with or without FireMotD.

For the other questions about a fix have you checked to see if there’s an open issue on Github?