[SOLVED] Openhab 2.3.0 with Habpanel, charts do not refresh

  • Platform information:
    • Hardware: Client on Raspberry 3, server on qnap 251+ running in a container
    • openHAB version: 2.3.0 running in a container on qnap 251+
  • Issue of the topic: Charts do not refresh in habpanel

Hi Guys,
I use Openhab with Habpanel as it perfectly fits my needs. I succeeded to install Openhab on my qnap 251+ in a container and to connect from any client. I have several Rasperries to collect data and one Raspberry with display to show some states and to control some devices.
Currently I’m stuck with the charts. I use chromium on the Raspberry in kiosk mode to show some sensor values in a dummy widget and additionally in a chart of type RRD4j and n3-line-chart. The dummy widgets update automatically, but the charts don’t update. As I run the client in kiosk mode in chromium on the Raspberry I have no reload button. There is only a resfresh button on the upper right corner which has no effect at all. The only way to refresh the page is to switch to another panel and back again. I tried firefox as an alternative but with the same result. Only the dummy widgets refresh, the charts are somehow static.
I doon’t have any idea how to fix or debug it. I found some similar postings but none of them cover habpanel. Any help is appreciated.

Solution: enable “Live-Update” in widget settings (currently it is on the last tab)

I have the same problem. I am using a Standard chart.

Where is this “Live-Update” setting from the solution?

I am seeing these exceptions in the Chrome browser console:
vendor.js:119 TypeError: Cannot read property ‘indexOf’ of undefined
at image.widget.js:70
at n (vendor.js:108)
at m.$eval (vendor.js:147)
at m.$digest (vendor.js:144)
at m.$apply (vendor.js:147)
at vendor.js:109

You need to select n3-line-chart Type


And then a third tab appears:


Thanks! This is working nicely. I had previous ignored the n3-line-chart because it looked too complicated.