[SOLVED]:OpenHAB 2.4 Docker Upgrade to 2.5M3: Issue-HabPanel is missing

I’m a relative newcomer but I have been running OpenHAB 2.4 stable in a Docker without any issue for the past 6 months. With the recent release of 2.5M3, and the pending final release at years end, my curiosity was piqued and so I decided to give it a try. After making a backup and testing that it worked, I proceeded to install/upgrade 2.5M3 over my 2.4 Docker. The installation went fine fine and after a few minutes I was able to load WebUI. PaperUI and BasicUI were both accessible with my items and site map intact. I used PaperUI to install the REST API Docs per the change log, but HapanelUI would not load even though Paper showed it was installed. I deleted all of the cache and tmp items, uninstalled HabPanel using PaperUI, restarted and reinstalled HabPanel, but still no HabpanelUI. I used the console to list the bundles and HabPanel 2.5M3 is shown as active. I stopped it and restarted it, but again no improvement.

I restored 2.4 and next tried to remove all of the cache and tmp items before upgrading to 2.5M3 but I got the same result. If I do a clean install to a new docker container, using a standard install HabPanel is shown in the WebUI.

Any ideas as to what may be causing this issue or approaches I should try? For now I am back to using my 2.4 Docker without issue, and I am content to stay there for now if this is a known issue that has yet to be fully addressed in 2.5.

Thanks in advance for ideas and thoughts.

I have continued to dig into this searching the forums for clues, and have identified the culprit that is causing HabPanel not to load in the 2.5M3 WebUI. It is the habpanel.config file located in userdata/config/org/openhab/. I’m not sure why this should be causing the problem as it loads fine in 2.4 and works without issue, but 2.5M3 chokes on it. If I remove the file then HabPanel appears as expected in WebUI. Going forward I doubt that I will be the only one with this issue when upgrading from 2.4.

To fix this problem I made a duplicate docker of my 2.4 install and removed the 2.4 HabPanel config file from /userdata/config/org/openhab directory prior to upgrading to 2.5M3. I then installed 2.5M3 over top of my 2.4 duplicate docker. The upgrade created a fresh hapanel config file in /userdata/config/org/openhab directory. Then, because I am running Docker I am able to have both 2.4 and 2.5M3 installed and running in separate Dockers, so I was able to use the PaperUI in 2.4 and 2.5M3. I navigated within 2.4PaperUI tabs to the Services/UI/HabPanel/Configure Tab and copied the Habpanel json. I then pasted this into 2.5PaperUI/Services/UI/HabPanel/Configure Tab on my 2.5M3 docker installation and restarted. Now everything seems to work fine with 2.5M3. I don’t know the exact nature of the root cause for this behavior, but this solution works and may help some one else done the road as we migrate to 2.5 and beyond.

I have stumbled over one other user that had issues with habpanel. Please report your findings in this thread about 2.5M3 testing as we are trying to round up all issues with this release.
And Bravo for researching and fixing you own issue :+1: