[SOLVED] OpenHAB 2.5 RC 1 Critical Issues

MQTT Not working.
Just to help those with this issue it has been opened on github here

and here.

I have reverted back for the moment with

sudo apt install openhab2=2.5.0~M6-1

cleared the cache and restarted.

@David_deMarco Does that mean that the fix is not working for you?

Hi JNK
Have not applied the fix as could not find clear info on how to apply it. Happy to apply and test if you can point me in the right direction. Confirm stable on M6 (I’ll update the post above)

Same to me, as well with Mosquitto.
all commandTopics works fine, but none of the stateTopics.

You can find the instructions on the GitHub issue you’ve linked:

Please update the “openHAB Core :: Bundles :: MQTT Transport” bundle with https://janessa.me/esh/org.openhab.core.io.transport.mqtt-2.5.0-fs.jar this one and report back. Instructions https://janessa.me/esh. option 2.

4 Likes

Somehow I have 2 MQTT transport bundles:

262 │ Active   │  80 │ 2.5.0.RC1                │ openHAB Core :: Bundles :: MQTT Transport
269 │ Active   │  80 │ 1.14.0.RC1               │ openHAB MQTT Transport Bundle

I’ve deleted the 1.14 and upgraded the other one to 2.5.0.201912101757.

So far everything seems OK. Maybe this was the cause of my MQTT issues I experienced with M6.

MQTT: For me only topics that are retained do not work. But normal ones work fine.

It looks like you had MQTT21 & MQTTv2 both installed

What exactly is not working? Please provide debug logs (or better trace).

1 Like

@David_deMarco linked an issue that was already merged. I’ll wait when next snapshot be out and will retest. For me only part of subscriptions were not working for some reason. No idea why.

This issue has been resolved by upgrading to the latest stable version.

Thanks @rkrisi I missed that bit (jetlag and system upgrade not good idea). Full steps in one place to help others given MQTT is used so much now. (updated with improved karaf command)

sudo systemctl stop openhab2
sudo sudo openhab-cli clean-cache
sudo systemctl start openhab2

Confirmed here that MQTT state updates now failing.

Open the Karaf console:

openhab-cli console
bundle:update org.openhab.core.io.transport.mqtt https://janessa.me/esh/org.openhab.core.io.transport.mqtt-2.5.0-fs.jar
logout

restart openhab - do not clear the cache

sudo systemctl restart openhab2

Confirmed that MQTT states are now working again - Can’t comment on retained messages. Note I also had some suspect issues with openhab-cli not stopping Openhab so playing it safe here.

thanks @J-N-K for prompt fix

Update: I had to reboot my rpi3 and the connection to the MQTT Broker failed with

OFFLINE - COMMUNICATION_ERROR io.netty.channel.AbstractChannel$AnnotatedNoRouteToHostException: No route to host: /10.88.87.180:1883

A manual stop and start of openhab resolved the issue.

2 Likes

There is an issue with usb-serial devices on RC1 as reported by @Andrew_Rowe, @davorf and I experienced it on Windows 10 and Raspberry PI (using openhabian 1.5): the serial items (zwave controller and RFXcom for me) keeps reinitializing on openhab level, it is fine on the command line (using lsusb, dmesg etc…). It was causing very high memory and cpu usage and even using swap, the pi was unusable after a few hours.

Switching to latest snapshot, for me it is 1774, fixes the issue

1 Like

That’s strange because 1774 doesn’t have any differences compared to RC1 regarding those bindings and the serial communications code AFAIK.

There’s a 1775 snapshot build now that’s the same as RC1 plus the MQTT fix and some ScriptEngineFactory changes.

Maybe you can check if the issue is resolved after restarting openHAB without clearing the cache?

1 Like

This solves also my issue below!

To save some steps, you can specify the bundle by name rather than number…

bundle:update org.openhab.core.io.transport.mqtt https://janessa.me/esh/org.openhab.core.io.transport.mqtt-2.5.0-fs.jar
6 Likes

Cool

1 Like

solved the problem for me :ok_hand: thank you!

I created this thread in the community forum and i was told that is related to the getEvent() issue.

I was not brave enough to create an issue, as i didn’t want to create more work for the project members and i thought there was already one as i thought this is related to the getEvent() issue.

Of course not! I am absolutely sorry if this was the message of my post. I am very grateful for the work of cweitkamp and the others who are contributing to this project. I just read his post and suspected that he did some work in the hue binding and is not able to pursue the support of the plugin anymore:

2 Likes

Ok i am filing and issue on github on the missing dimmer switch events:

3 Likes

Not sure if this is new “feature” or an unintended consequence of recent changes, but it seems that every time I use PaperUI to add or delete a Thing or Item, an OpenHAB System restart is initiated. This did not seem happen prior to 2.5.0M6. I am running OpenHAB in Docker. Did I miss something along the way?
UPDATE: This issues seems to have resolved. I rolled back to 2.5.0M5, deleted the cache and tmp directories, updated to 2.5.0RC1 and restarted the docker 2 twice. Since doing this I have not noticed any restarts when I add Things or Items using PaperUI. I believe this glitch is real, but was easily resolved at least for now.

UPDATE2: Since I now know this thread is not intended as an alternative to bug reporting on git, this update is more of an FYI. However the restarts when using PaperUI to add a new Thing or new Item are back. It’s more of an annoyance for me and I may not have even have noticed except that I have a rule that triggers when “system started” and results in a notification being sent. However I wonder about the efficiency of this approach when adding a large number of Items or Things with PaperUi.

Before I do anything on git, can anyone confirm if this behavior Is by design or indeed a bug. As I said, I did not notice this before M6, and my rules have not changed.

1 Like