[SOLVED] openHAB 3 Docker installation - Configured config paths empty

Hi everyone,

I am currently running openHAB 3 on a Raspberry PI 4 8GB with Docker. I configured the container to use a NFS share provided by my NAS (I am afraid of losing my configuration).

In my opinion I setup everything as described in the manual.
I already configured some devices.

Now I am a bit confused as the openhab/conf, etc folders are empty. I looked up the volumes in my p

When I check the directory on my pi everyfolder is empty:

Likewise, I’m surprised that after a chown, the owner of the folder was still root.

Am I missing something?

Best regards,

First of all welcome Herri :slight_smile:

To answer the question I need a little more information.

  • Does the container start? Or is it giving errors?
  • Have you tried without the NFS mount first, so just normal volumes? To make sure nothing else it wrong.
  • How do you start the container, do you set a specific user/group?

Hi I_grave and thank you :smile:,

  • The Container starts without errors. I am also was able to install some bindings and configure Things and Items.

  • In my portainer I can see that the volumes used by the container.

  • To start the container I used the command set from the docker page.

sudo docker run \
  --name openhab \
  --net=host \
  -v /etc/localtime:/etc/localtime:ro \
  -v /etc/timezone:/etc/timezone:ro \
  -v openhab_addons:/mnt/NAS/openhab/addons \
  -v openhab_conf:/mnt/NAS/openhab/conf \
  -v openhab_userdata:/mnt/NAS/openhab/userdata \
  -e "EXTRA_JAVA_OPTS=-Duser.timezone=Europe/Berlin" \
  -e "OPENHAB_HTTP_PORT=8080" \
  -e "OPENHAB_HTTPS_PORT=8443" \
  -d \
  --restart=always \

Thank you,

Hi, I think your config for the volume should be the other way around. NFS share should be first.
This is what I use in a yaml:

      - "/etc/localtime:/etc/localtime:ro"
      - "/etc/timezone:/etc/timezone:ro"
      - "/opt/openhabdevtest/openhab_addons:/openhab/addons"
      - "/opt/openhabdevtest/openhab_conf:/openhab/conf"
      - "/opt/openhabdevtest/openhab_userdata:/openhab/userdata"

Hi Edward,

I think you are absolutly right. :face_with_open_eyes_and_hand_over_mouth: :face_in_clouds:

I check the container again and saw this:

So I think I should get the config and change the container var.

Best regards,

1 Like

Hi Michael, if my suggestion solved your issue please mark your post as Solved :slight_smile:

1 Like