[SOLVED] Openhab Hang with espeasy remote plug after hours of use


I was using Openhab on an ubuntu 14 since month with many sensor based on espeasy firmware with esp8266 chip.
No problem, all was working nice.
I tried to add a remote power plug with button.
After that My openhab hang randomly after I used my remote plug.
Habopen is responding, I can click on switch but no update are made.

Logs are no more logging, like all was stopped suddenly.
I was suspecting an hardware problem on my ubuntu so i move to a virtualized windows 2016 and the same problems happens even with Openhab updated to milestone 2.5.0.M1.

If the remote power plug is not plug, no problem.

here is my items for the plug :
Switch ESP_Prise_Piscine “Prise 1 [%s]” (atelier,prise){mqtt=">[mosquitto:/ESP_Prise_Piscine/gpio/14:command:ON:1],>[mosquitto:/ESP_Prise_Piscine/gpio/14:command:OFF:0],<[mosquitto:/ESP_Prise_Piscine/Relai/State:command:MAP(switch.map)]"}

On the remote power with latest espeasy firmware with this rule :

On System#Boot do
Monitor GPIO,14
Publish %sysname%/IP,%ip%

On Rules#Timer=1 do
Publish %sysname%/IP,%ip%

on GPIO#14=1 do
TaskValueSet 2,1,1

on GPIO#14=0 do
TaskValueSet 2,1,0

on bouton#State Do
if [bouton#State]=1

And a generic dummy device send his state each 10s. The state is the taskvalueset of the the rules.

I can provide more log or other.

I hope to have been clear.

have you an idea of what is the problem ?

Thanks in advance.

If there is a bug, and by all appearances there is a bug, it is most likely going to be in the MQTT 1.x binding. This isn’t a guarantee but with the limited amount of information available it’s my best guess.

Unfortunately if the problem is in the MQTT 1.x binding, I suspect the “solution” is going to be to upgrade to the 2.5 M1 or later version of the MQTT binding which works completely differently. Both bindings can be installed and used at the same time so you can try it out for this one Item and see if this problem disappears or persists.

If the problem persists then the problem is not inside the MQTT binding and we need to look elsewhere.

2.5 M1 version of mqtt bindings is not available in my bindings. ( only 2.4.0 is available and already installed )
Do I need to upgrade to latest developpement version of openhab ?

That will be the easiest way to get it.

ok thanks, i will try and come back to give a feedback.


I didn’t take the time to solve the problem before as I did not use the the remote plug anymore.
This week-end, I’ve added a new item in my network to display on openhab french energy system.

And the same problem occurs…
It was even worse, when the remote item is in the network, openhab hang in 10 minutes. If I set the remote item to send data only 1 time per 10 minutes, it hang in 1Hour.

So I decided to change all my mqtt bindings to 2.5m1 ( the remote energy system was already in mqtt 2.4 ).

Before to do, i have updated all my items and things to mqtt 2.4 and removed the mqtt 1.x plugin from openhab.

After that, all is working ok ! no need to update to 2.5.

Before : a mix of mqtt 1.x and 2.4 was working with no problem.
adding one item with mqtt 2.4 ( a remote plug or remote teleinfo energy ) and openhab was hanging.
after : all items and things in mqtt 2.4 and all is ok.

The only thing that I suspect is that the remote plug or the teleinfo was sending many more data at a very higer rate than the others items.

I hope this can help others, and thanks for the help.