[SOLVED] OpenHab is not updating item's values after blackout

A few days ago I had power loss for a few minutes. From that time openHab is not updating item’s values. All of them are connected through mysensors binding, but mysensors seems to work properly. Here how it looks in BasicUI:

And here is log example:
[DEBUG] [rsAbstractConnection$MySensorsReader] - Message from gateway received: 0;101;1;0;1;94.86
[DEBUG] [rs.internal.gateway.MySensorsGateway] - Node 0 found in gateway
[DEBUG] [rs.internal.gateway.MySensorsGateway] - Child 101 found in node 0

And here is example how it looked before:
[DEBUG] [rsAbstractConnection$MySensorsReader] - Message from gateway received: 0;101;1;0;1;91.38
[DEBUG] [rs.internal.gateway.MySensorsGateway] - Node 0 found in gateway
[DEBUG] [rs.internal.gateway.MySensorsGateway] - Child 101 found in node 0
[DEBUG] [ensors.handler.MySensorsThingHandler] - Updating channel: hum(V_HUM) value to: 91.38
[DEBUG] [ensors.handler.MySensorsThingHandler] - Setting last update for node/child 0/101 to 2018-12-04T22:05:32.000+0100

Thanks in advance

Please provide more info like what are you running OH on. If it’s an RPI and your using a SD card then it may have been corrupted when the blackout occurred. You may be able to fix this by simply cleaning the cache and tmp files but who knows.

My car won’t crank, tell me how to fix it. How this analogy helps and please take a few minutes to read the following topic.


can you post your items definition?


Number outHum01 "Wilgotnosc [%.2f %%]"          <humidity>      (gHumi,gWeather)        { channel="mysensors:humidity:gateway:humi01:hum" }
Number outTemp01 "Temp. I2C [%.2f °C]"          <temperature>   (gTemp,gWeather)        { channel="mysensors:temperature:gateway:temp01:temp" }
Number outPress01 "Cisnienie [%.2f hPa]"        <pressure>      (gPressure,gWeather)    { channel="mysensors:baro:gateway:press01:pressure" }
Number outLight01 "Poziom swiatla [%.1f lux]"   <outdoorlight>  (gLight,gWeather)       { channel="mysensors:light-level:gateway:lightlvl01:level" }
Number outTemp02 "Temp. DS [%.2f °C]"           <temperature>   (gTemp,gWeather)        { channel="mysensors:temperature:gateway:temp02:temp" }
Number outTemp03 "Temp. DS [%.2f °C]"           <temperature>   (gTemp,gWeather)        { channel="mysensors:temperature:gateway:temp03:temp" }
Number outTemp04 "Temp. DS [%.2f °C]"           <temperature>   (gTemp,gWeather)        { channel="mysensors:temperature:gateway:temp04:temp" }

I am running Openhab 2.3.0-1 on Raspberry Pi 3 B+
Using SD card.

Anyway, I decided to reinstall OpenHab from blank. I have a few resons for it. It will solve problem for 99% - I will response after christmas.

After reinstall of OpenHab on pendrive everything obviously works fine. I did not discover what was reason for previous problems. But now I will research for UPS solution to avoid consequences of blackouts in future. Thanks.

Glad you have it back up and running.:+1: The reason is most likely the blackout cause SD card corruption.

Please mark the topic as solved by clicking the square box (lower right corner) on the post that provided the solution and edit the title to begin with [Solved].