[SOLVED] Openhab is running but can't be reached on ip

  • Platform information:
    • Hardware: CPUArchitecture/RAM/storage
    • OS: what OS is used and which version
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version:
  • Issue of the topic: please be detailed explaining your issue
  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:
    Hello, i have openhab2 running for a while now. This morning i removed habmin ui in paperUI and installed it again (don’t know if this could be the cause). Afterwards i could no longer reach openhab by ip adress. I had this problem before, and only way to resolve this was a cold reboot. But this time it didn’t help. Still can’t reach ip of openhab. Cli still workes and i can see openhab is running normally in the logs. Does anyone have an idea what happened? I’m a noob at linux.

Running openhab2 on a raspberry pi 3B

Sorry guys, for some reason i do not understand it just fixed itself. No reboot or nothing. I couldn’t reach ip from android phone. Not in browser and not in app. Just fired up pc and tried ip in browser and it works. Tried again on phone and allso workes. I don’t understand, but hey problem is fixed

When you make a change and restart OH, it takes a few minutes for everything to get loaded back up. Not sure how long you had to wait and what you mean by a cold reboot but try and avoid killing the power as a method to restart. Killing the power on an RPI is not good for the SD card and doing that often will corrupt the card.

Yes i know i run the risk of corrupting the sd by cutting the power but my openhab runs for a few weeks and then suddenly it stops working. I can still log in with ssh with username and password and connection gets shutdown right after inputting password. At this moment it is allso impossible to access openhab by browser or app. My only option is cutting the power and rebooting at this point (or is there an other option). After reboot everything works like it should again.

I am allready booting from usb flash drive because my previous sd card got corrupted (not by cutting power on purpose but poweroutage). Since then i got a eps for my rpi and ordered a mSATA hat with 128GB SSD. Still waiting for the hat. A friend of mine thinks the problem could be i’m using to much memory so i hope openhab will no longer go out after a few weeks once i get everything migrated to mSATA SSD. Any thoughts?

Try connecting the RPI to a monitor via HDMI cable and hook up a USB keyboard. That should prevent the shutdown issue when using ssh but there’s still a major problem b/c ssh shouldn’t do that.:thinking:

I would check to make sure your power supply is good, 5v 2.5A is recommended. Moving to a USB is a quick solution but the memory works the same as SD cards so corruption can still happen.