[SOLVED] openHAB not starting after update (ServerSessionImpl - InterruptedByTimeoutException: null)

  • Platform information:
    • Hardware: Raspberry Pi 3 Model B Rev 1.2
    • OS: openHABian (current release) / Raspbian GNU/Linux 8 (jessie)
    • Java Runtime Environment: openjdk version “1.8.0_152”
    • openHAB version: 2.5.0~S1479-1 (Build #1479)
  • Issue of the topic:
    Today I updated my OH2 installation by using the openhabian-config tool. The tool first updated itself and then I did a OH2 update. After restarting OH2, the dashboard is not reachable (instead a message is shown that the UIs are being configured). After a while (approximately 10 minutes) the following message in openhab.log comes up:
    2018-12-26 12:16:58.015 [WARN ] [shd.server.session.ServerSessionImpl] - exceptionCaught(ServerSessionImpl[openhab@/])[state=Opened] InterruptedByTimeoutException: null

After updating you may want to try cleaning the cache and rebooting. You can use the following commands for this.

sudo systemctl stop openhab2

sudo openhab-cli clean-cache

sudo reboot

For my server a single reboot worked but others have reported that rebooting a few times was needed.

Hope this helps.

Thank you very much. Cleaning the cache made it working again!

Glad to hear you have it working.:+1:

In addition to editing the title, please click the square box (lower right corner) on the post that provided the solution.