[SOLVED] OpenHAB not starting anymore after update to 2.5.2 (maven download error)

Hi All!

I just updated my openHAB Installation on Debian Buster from 2.5.1-2 to 2.5.2-1. Unfortunately, it’s not working anymore. It starts but shows these error messages in the log:

2020-02-26 14:54:39.727 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-modbus, openhab-binding-exec, openhab-misc-market, openhab-transformation-javascript, openhab-binding-tcp1, openhab-binding-network, openhab-transformation-regex, openhab-ui-habpanel, openhab-transformation-jsonpath, openhab-binding-wifiled, openhab-transformation-xpath, openhab-ui-restdocs, openhab-binding-mqtt, openhab-persistence-rrd4j, openhab-transformation-map, openhab-ui-basic, openhab-ui-classic, openhab-ui-habmin, openhab-transformation-xslt, openhab-binding-homematic, openhab-binding-expire1, openhab-transformation-exec, openhab-ui-paper, openhab-transformation-scale': Error:
Error downloading mvn:org.openhab.persistence/org.openhab.persistence.rrd4j/[1.14.0,1.15)

I then found the file “tmp/mvn/org/openhab/persistence/org.openhab.persistence.rrd4j/resolver-status.properties”, which contains:

NOTE: This is a Maven Resolver internal implementation file, its format can be changed without prior notice.
#Wed Feb 26 14:54:39 CET 2020
maven-metadata-openhab.xml.error=Could not transfer metadata org.openhab.persistence\:org.openhab.persistence.rrd4j/maven-metadata.xml from/to openhab (https\://openhab.jfrog.io/openhab/libs-release/)\: openhab.jfrog.io

Internet is working, multiple restarts/reboots and “openhab-cli clean-cache” didn’t not fix it.
I don’t know what else to do, can someone please help?


Well, as it seems that wasn’t fully correct, DNS partly didn’t work which seems to have broken that Maven download.

^_ If the issue is resolved, please close your topic. :slight_smile:
I can see a [SOLVED] “tag” in your topic name, but no solution tick :white_check_mark:

Cheers :beers:

Actually, I was searching for such a button when adding the [SOLVED] tag, but somehow missed it.
Thanks for the hint!

1 Like

No problem, glad I could help :grin: