[SOLVED] OpenHAB not working after update to 2.5.2 from 2.5.1

  • Hardware: R Pi 3B+ w/ 64GB SD Card

  • OS: Openhabian

  • Java Runtime Environment: openjdk version “1.8.0_222”
    OpenJDK Runtime Environment (Zulu8.40.0.178-CA-linux_aarch32hf) (build 1.8.0_222-b178)
    OpenJDK Client VM (Zulu8.40.0.178-CA-linux_aarch32hf) (build 25.222-b178, mixed mode, Evaluation)

  • openHAB version: 2.5.2

  • Issue of the topic:
    My OpenHAB is basically broken after the upgrade to v 2.5.2. My log shows that the items files, things files, and sitemaps are loading, but I have no control of my devices either via PaperUI or Alexa. Alexa responds that the hub the device is connected to is not responding. When I access the configuration all the things are showing as uninitialised, and there are no bindings showing up in the binding config menu. When I search to add a binding (hue binding for example) it’s showing as already installed. When I scroll through the bindings list in the add-on menu, all of my bindings from 2.5.1 are showing as installed. I have no clue what to do to fix this.

I did a standard update using the commands:

sudo apt-get update
sudo apt-get upgrade

Most indications are that a few dozen restarts are needed.

I hope you’re joking! :weary:

dozen was possibly a slight exaggeration.

Clear cache too.

Tried to install a random Binding and that got everything back up. :no_mouth: