[solved] OpenHAB on Synology can't find sitemap


Subject line says it all really. I’ve just installed the OpenHAB 1.7.1 on my Synology and the service seems to start just fine. I’ve created a shared folder called ‘public’ and placed my sitemap file in the volume1/public/OpenHAB/configurations/sitemaps folder (other config and addon files in the folders suggested). I’ve given all users r/w permissions to that folder (I haven’t set up a specific user for openhab - do I need to do that? Doesn’t seem to be any instruction to do that but Christian Mathis’ post here (https://groups.google.com/d/msg/openhab/VfJkbf6WLdQ/6XpkPyozrOIJ) seems to talk about an openhab account).

When I go to the site URL I get the 500 error ‘Sitemap ‘mysite’ could not be found’. When I try to connect using the Android app, I get a message saying ‘openHAB returned empty sitemap list’.

What am I missing?!

Thanks in advance,


Ok, my bad, I’ve solved that problem - for the benefit of others, when you install OpenHAB on the Synology it creates a new user called OpenHAB. You need to give that user r/w permissions on the public folder. Note that for me (at least) then OpenHAB user didn’t show up in the list of users when I tried to amend the public folder’s settings. I had to go through the Users control panel item and assign the rights that way.

The next problem to fix is why the webpage freezes once it’s been open for a few seconds… this happens on the Win 8.1 and Win 10 machines I have…

Hey Ben,

thanks for your post! It helped me to assure that I’m not on the completely wrong track finding out where there is the issue with setting up OpenHab on my Synology - I already started banging my head against the desk… :tired_face:
To enhance a bit on the details you gave, I would add the following points to go through:

  • best is if you set up the /volume1/public/OpenHAB/… folders at the very beginning before installing OpenHab and the example package
  • I did this via SSH, logging in as root (you might have to enable your admin account but ensure to use root for login in SSH console, in addition SSH access might need to be activated in DSM)
  • check that after openHab and demo package installation the configurations folder contains files like the openhab_default.cfg and folders like scripts, sitemaps, …
  • check that the owner of the files and folders is the user openhab - chown -R openhab
  • check that the access rights are given to all files and folders - chmod -R 777

Hope you have a quicker start into it!

Hi Michael, I see that you’re having a lot of knowledge with setting up openHAB on the Synology NAS. The problem I run into is that I can’t find the folders like scirpts, sitemaps etc after installing openHAB… Do you know how to fix this?

Hi Jim,

are you able to use Docker? It is much easier.



Never heard of Docker. Where is it used for?


Hi @Jim_Verspuij,

it is a kind of virtualization. Search for „Docker Synology Package“. There you can see if your NAS is Docker compatible. It is much easier than installing openHAB it the native way on a NAS.