[SOLVED] OpenHAB openwebnet bindings

Hi All this is my first thread, sorry for my bad english and because I’m a beginner.
I installed on my qnap in a container the version of openhab 2.4. I have a very old bticino system, and my gateway is a F453AV, I have even managed with the old 1.X bindings to configure all the lights.
Now i have installed the OpenWebNet Binding (beta9-2) of the great Massi (Very Thanks). I tried to configure my first window automation and then I would like to try to open the gate connected to the video door phone.
This last one works with this frame in bus scs :

 *6*10*4000##

Things:

Bridge openwebnet:bus_gateway:mybridge "MyHOME F453AV" [ host="192.168.1.35", passwd="xxxxx" ] {
    
      bus_automation           GF_LivingDining_Window       "Finestra Cucina"     [ where="91", shutterRun="AUTO"]

}

item:

Rollershutter  GF_LivingDining_Window  "Finestra Cucina [%.0f %%]"       <window>           (GF_LivingDining, gShutters)  [ "Blinds"   ]  { channel="openwebnet:bus_automation:mybridge:GF_LivingDining_Window:shutter" }
Sitemap:
        Text label="Finestra" icon="window" {
            Default item=GF_LivingDining_Window label="Finestra Cucina"
        }

For my bad dont work!
Can someone tell where I’m wrong?

Look at this example


Remember to enter the correct password
Run it all through PaperUI, after we see the sitemaps
If you have problems publish the log, so we can see what kind of error

At the moment it is not possible with 2.0 bindings
You can do it with bindings 1.0

After entering the configuration in the files.

Check under Configuration - Things
image
You must see if your bus is online

If the bus is online, press the physical shutter switch.
You have to see your bus_automation is online

Read the readme, but the gateway bus must first work

Thank you for the quick reply.
I put the right password only I did not report it here. The password is the default one: 12345
The Gateway bus is ON-LINE, instead the automation does not.
Now I try from the physical command to see what happens.

I tried with version 1.0 of the bindings but I did not succeed now put the settings:
Item:

Switch    GF_Kitchen_Door          "Cancelletto"                         <door>             (GF_Kitchen, gPower)    ["Switchable"]      {bticino="if=default;who=6;what=10;where=4000"}
Group:Switch:OR(ON, OFF)           gPower     "Cancelletto"   <poweroutlet>     (Home)

Sitemap:

        Text label="Cancelletto" icon="door" {
            Default item=GF_Kitchen_Door label="Cancelletto"
        }

Many thanks for help me.
Grazie Michele


Unknow …
I pressed the physical command but tells me unknown.
I have the doubt that I was wrong in the command where=“91”
There are a way to find out the exact address of this automation?
Thanks

For the first problem i have solved: the error are sintax i print shutters with s final but are gshutter.
And now!

I solved now the problem with mi open door …
I put in my item : {bticino=“if=webserver;who=6;what=10;where=4000”} and not {bticino=“if=default;who=6;what=10;where=4000”} and this solved the problem.
Best regards to all.
Ivan

1 Like

great, good Ivan

Ivan,
watch the animation, above your configuration and under mine.
Cancello2

Save with name icon openHAB-conf\icons\classic
cancelletto.svg
cancelletto-off.svg
cancelletto-on.svg
cancelletto-on cancelletto-off cancelletto-on

the expire function, timing, is used to turn OFF after 2 seconds, you can change the seconds as you wish

The expire binding is in version 1.x to install see image.

press install

.items

Switch    GF_Kitchen_Door          "Cancelletto"     <cancelletto>   (GF_Kitchen, gPower)    ["Switchable"]      {bticino="if=webserver;who=6;what=10;where=4000", expire="2s,command=OFF"}

.sitemaps

Text label="Cancelletto" icon="cancelletto" {
    Default item=GF_Kitchen_Door label="Cancelletto"
	Switch item=GF_Kitchen_Door label="Cancelletto1" mappings=[ON="Apri"]
}
1 Like

Oh Thanks!
On the PC browser everything works perfectly, while on the smartphone application it does not show me the icons.I believe the application of the mobile only has the icons of the basic set of openhab?
Regards
Ivan

Sorry but I have two other questions:

  1. The first is a bit off topic, is there a way to make google home upload the new openhab devices without disconnecting and reconnecting the openhab skill?
  2. I noticed that the automation of the window I mentioned with the [“Blinds”] tag on google home is not recognized, i have configured Configuration > System > Item Linking > Simple mode > SAVE but nothing has changed.
    Thanks
    Ivan

Yes, I’m looking for a different way to do it
If I find a different way I send you a post

I do not have google home

Thanks Michele for the super fast response.
I’m waiting to know if anyone else knows how to do it.

This method that you showed me was very useful to configure a bell that has the frame * 1 * 0 * 81 ## that is controlled by the cords that are in the bathrooms. I configured how you taught me and I play it for one second each time the command is played.
Very useful then thank you!!
Ivan
Sorry for my bad translate …

Solution to have dynamic icon even on the app.

.items

Switch 				Pul_cancelletto 				"Cancelletto" 						<door>	        (C_Esterno, G_Pulsante) 	[ "Lighting" ] 			    {bticino="if=webserver;who=6;what=10;where=4000" , expire="2s,command=OFF"}
String  			Pul_virt_cancelletto 			"Vituale Cancelletto" 				<door>			(C_Esterno, G_Pulsante)  {expire="2s,command=CLOSED"}

.rules

rule "cancellettovirt"
    when
        Item Pul_virt_cancelletto changed from CLOSED to OPEN 
    then
        Pul_cancelletto.sendCommand(ON)          
end

.sitemap

Switch item=Pul_virt_cancelletto 	label="Cancelletto" 	mappings=[OPEN="Apri"]
1 Like

good work for me works properly!
Thanks for your help Michele
Ivan

1 Like

In this line I replaced [ “Lighting” ] with [ “Switchable” ] to allow google home to recognize a switch and not a light.
Many Thanks
Ivan

1 Like