[Solved] OpenHAB web sitemap freezes when I add a specific Light

Hi All,

I’m just getting started with OpenHAB (Arch Linux, OpenHAB version 1.8) and I started by adding the hue binding, but I’m running into an issue with one of the lights. for some reason, whenever I add greathallHue to a group, that group will cause the webpage to “freeze” until I reload the page. All other lights work fine.


/* Groups */
Group bedroom
Group greatroom
Group lights
Group weatherHome

/* Weather */
Number  Temperature_F   "Temperature [%.2f °F]" (weatherHome)   {weather="locationId=home, type=temperature, property=current, unit=fahrenheit"}

/* Lights */
Color bedroomHue "Bedroom Lamp" <hue> (bedroom,lights) {hue="1"}
Color greatroomHue "Greatroom Lamp" <hue> (greatroom,lights) {hue="5"}
Dimmer bedhallHue "Bedroom Hallway Light" <hue> (greatroom,lights) {hue="3;brightness"}
Dimmer greathallHue "Greatroom Hallway Light" <hue> (greatroom,lights) {hue="4;brightness"}


sitemap home label="Home"
  Frame {
    Group item=weatherHome label="Home Weather" icon="sun"

  Frame {
    Group item=lights label="All Lighting" icon="hue"
    Group item=bedroom label="Bedroom" icon="bedroom"
    Group item=greatroom label="Greatroom" icon="smartheater"


Anybody have any ideas? Doesn’t look like I’ve misspelled something so I’m at a complete loss, and I tried searching but couldn’t find anything

I had a similar issue. Try changing your items to include [%s %%] inside your label value.

Dimmer bedhallHue “Bedroom Hallway Light [%s %%]” (greatroom,lights) {hue=“3;brightness”}
Dimmer greathallHue “Greatroom Hallway Light [%s %%]” (greatroom,lights) {hue=“4;brightness”}

This workaround should no longer be required in openHAB 1.8.1. Please upgrade to 1.8.1, remove the workaround and let us know!

Oh thanks! Sorry, I didn’t even know a 1.8.1 was out. I’ll give it a go this evening and report back.

This fixed my Issue. Thanks! I’ll upgrade to 1.8.1 as soon as I get a chance but for now this is solved.

I also confirm it solves the issue with locking up the UI. What it doesn’t solve, however, is the slider working. If you remove the [%s %%] 1.8.1 no longer locks with multiples but the slider no longer works either (as it didn’t in 1.8.0 either).

I also find that designer is broken but I’ll post that elsewhere.

It would be very helpful if you could open issues for the problems you find. If sliders are broken in 1.8.1, this should get a proper bug report! Unless what you experience is the same as #2900, in which case please ask that that issue is reopened. Thank you.

OK, I will look into that. I apologize. I’m no expert on this stuff so I tend to shy away from opening bug reports as I figure I’m doing something wrong. I truly want to be a help and not a hinderance or burden.


Lots of improvements come from people who report that something seems wrong. But if you think there might be issues with your items, sitemap or rules, maybe we should look at them here first just to rule out possibilities? … sorry, I guess these are the items?

Dimmer bedhallHue "Bedroom Hallway Light [%s %%]" (greatroom,lights) {hue="3;brightness"}
Dimmer greathallHue "Greatroom Hallway Light [%s %%]" (greatroom,lights) {hue="4;brightness"}

I don’t have hue myself but hopefully others might have ideas?

Oh, in this case I think it actually is a bug. Those are the OP’s items not mine. I’ll read through the bug you linked to see if it is the same and go from there.

OK, false alarm. Perhaps my browser was caching junk. I did some testing this morning and the slider DOES work. I find that adding [%s] still to the label gives you the % of light level which is nice but is NOT required.

@watou, is there a recommended place for making enhancement suggestions? I assume that would be different from opening a bug.

It seems to work to start a discussion here on the forum. It’s the easiest place to refine an idea, and then someone might submit a pull request.