[SOLVED] Openhab will not go online

Hi…Very new to this. I got every thing up and running on Lubuntu 18.04. Then wanted to setup remote access. I got uuid and secret, started my account it was offline. Did reboot refresh of myopenhab but nothing works. Still oflline. My Java version is Can anyone help me???

See if this gives you any clues:

grep -i cloud /var/log/openhab2/openhab.log

Hi, So I did what OMR said and this is what I got…

2018-11-18 21:46:49.207 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: not authorized
2018-11-18 21:47:14.462 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: {}
at io.socket.engineio.client.Transport.onError(Transport.java:71) [209:org.openhab.io.openhabcloud:2.3.0]
at io.socket.engineio.client.transports.PollingXHR.access$100(PollingXHR.java:19) [209:org.openhab.io.openhabcloud:2.3.0]
at io.socket.engineio.client.transports.PollingXHR$6$1.run(PollingXHR.java:124) [209:org.openhab.io.openhabcloud:2.3.0]
at io.socket.thread.EventThread$2.run(EventThread.java:80) [209:org.openhab.io.openhabcloud:2.3.0]
2018-11-18 21:47:14.564 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = 5ca0cb72-9f20-4205-b09e-b2da263ff6b9, base URL = http://localhost:8080)

Can anyone help??

can you post a screenshot from PaperUI -> Conf -> Services -> IO -> OH Cloud ?

can you login on https://myopenhab.org/login ?

Check again your UUID & Secret on https://myopenhab.org/account

can you login on https://myopenhab.org/login ? Yes

Check again your UUID & Secret on https://myopenhab.org/account
I have checked and re-entered 2 or three times.

I will send the screenshot as soon as I am home.

Strange that it doesn’t show how many Items you have selected to expose…

In my case, I have selected 2 and it displays that info:

Can you see them as selected if you browse that list?

yes I took them out yesterday as I tried everything

Hi again,
Does anyone think it may have something to do with Lubuntu? I thought maybe I go back to Ubuntu 16.04 and reinstall. I can not find a 32 bit install for Ubuntu 18.04 so thats why I went with Lubuntu. Or does anyone have any other ideas?? Thanks!!

I’m running openHAB on Ubuntu 16.04 and it works like a charm, maybe worth a try.

1 Like

which java are you using??

which java are you using??

@Steve_J you can use the @ symbol then type or select the users name from the drop down. This sends a notice to the user that their name has been mentioned and often results in a faster response.

If you haven’t went thru the forum tutorial, take a few minutes to do so. It provides several tips, like the one above, for using the forum.:wink:


java -version


But now I see you need a 32 bit version, and I’m running 64.

OK I finally am online!! Next problem. :tired_face:
I cannot connect the app outside of my wifi. I have read everywhere and tried many differnt things but no avail.
Anyone have any ideas???

Hi Steve,
Two comments, maybe good to mention what you did to get online. Other users will learn from it.

Secondly to connect to your setup outside of your own WiFi you can install the openHAB cloud binding and setup your cloud service. There are other options, but I don’t have experience with that myself.

Some hints here, maybe …

1 Like

How? I am facing the same issue…

@Steve_J please state how you got it working… thanks