[SOLVED] OpenHab won't load GIT

Been trying for 2 days to get OpenHabian 2.4 to install and I am about brain dead at this point. Barely know enough Linux to plug the thing in but trying to learn. I have a Pi3B, flashed 2.4 install to a genuine Samsung 32G card with Etcher on a Windows machine. Plugged the card into the Pi and let 'er rip. It gets down to a common place where some have issues…

[openHABian] Updating repositories and upgrading install
ed packages… OK
[openHABian] Installing git package… FAILED
[openHABian] Initial setup exiting with an error!

I have tried to log in to the Pi from the Pi itself and through SSH. I CAN log in to both but get exactly the same thing… the list of failure messages and NO cursor or prompt to try and do apt-get or anything. I have had no luck at all getting a prompt. I have tried to take the card and look for the config file to edit it as I have seen on a couple trouble posts where they put in a dev-null comment (or something like that) into the git update line to prevent it from trying to update but windows sees the card as unusable without formatting it. Tried 2 different Pi3B’s and 3 different SD cards. Same exact results. Using a good phone charger that my Pi with Raspbian likes (doesn’t ever give me a voltage issue warning).

What next?

What’s the amp output of the power supply?
Do you have anything blocking OH from the internet like a firewall?
Have you tried changing the DNS (in your router) to use something like google ( and connected the RPI directly to the router, or as close as possible?

Took some trial and error and a few bucks on Amazon to resolve this issue. Come to find out that the wall wart supply I was using that said was 2.5A was actually a lying pile of poo. Started browning out at 1.78 amps. I bought some 5A rated 12v to 5v buck converters and connected them to my lab bench power supply and the install went like butter! Now i can get to the good stuff!

Not uncommon for most wall warts.:expressionless: Glad you found the issue and got it resolved.:+1: Having a poor power supply has resulted in several users failing to get OH running and is usually the first thing to check.:wink:

Please mark the post solved by clicking the square box on the post that provided the solution and edit the title to start with [Solved].