[SOLVED] OpenHab2 and MPD

Sorry, I forgot to answer this part earlier. From the console you can increase the log level to DEBUG or TRACE for more log info needed to troubleshoot. See the doc’s for how to

@robml I found no open issues for MPD on github so hopefully you have it installed and working. If so please mark the topic solved by clicking the square box on the post that provided the solution and editing the title to start with [Solved].

If your still having problems installing the binding I have only two other suggestions. First is try an older jar file and see if it will install then use the console to update the binding (bundle update). Here’s a list with several MPD jar files.

Second is a work around using mqtt found here.

Awesome, thanks a lot! Great help! :slight_smile:

I can see some traces regarding the addon listing services and getting registered. Now I would like to add “things” but the binding still missing in paper ui, should I try just using the basic UI?

openhab.log:2019-02-03 20:20:29.082 [DEBUG] [org.apache.felix.configadmin ] - Registering service [org.osgi.service.event.EventHandler, org.osgi.service.cm.ManagedService, id=348, bundle=234/file:/usr/share/openhab2/addons/org.openhab.binding.mpd-1.14.0-SNAPSHOT.jar]
openhab.log:2019-02-03 20:20:29.083 [DEBUG] [org.apache.felix.configadmin ] - Scheduling task ManagedService Update: pid=[org.openhab.mpd]
openhab.log:2019-02-03 20:20:29.084 [DEBUG] [org.apache.felix.configadmin ] - Running task ManagedService Update: pid=[org.openhab.mpd]
openhab.log:2019-02-03 20:20:29.084 [DEBUG] [org.apache.felix.configadmin ] - [ManagedService Update: pid=[org.openhab.mpd]] scheduled
openhab.log:2019-02-03 20:20:29.084 [DEBUG] [org.apache.felix.configadmin ] - Updating service org.openhab.mpd with configuration org.openhab.mpd@-1
openhab.log:2019-02-03 20:20:29.108 [DEBUG] [mpl.info.InfoBundleTrackerCustomizer] - Ignore incorrect info null provided by bundle org.openhab.binding.mpd

1.x bindings do not use things so you will only need to configure an items file for the binding. See the documentation for further detail on how to setup the binding to work with OH.

Just a side question:
Is it possible to use the items defined for BasicUI (mpd controls for instance) into the PaperUI? or for that matter within a dasboard?

Thanks again!

Hi there,
maybe it would help someone as the mpd installation is not really that straightforwrd, especially for beginners, so sharing my experience

Downloaded https://openhab.jfrog.io/openhab/libs-pullrequest-local/org/openhab/binding/org.openhab.binding.mpd/1.14.0-SNAPSHOT/org.openhab.binding.mpd-1.14.0-SNAPSHOT.jar
and placed it into

restarted the openhab2

now I can see that it is installed
openhab> bundle:list | grep -i MPD
191 │ Installed │ 80 │ │ openHAB MPD Binding

but when I try to activate it I get the following error
openhab> bundle:start 191
Error executing command: Error executing command on bundles:
Error starting bundle 191: Could not resolve module: org.openhab.binding.mpd [191]
Unresolved requirement: Import-Package: org.openhab.core.binding

Checked that
The “Configuration>System>Add-on Management>Include Legacy 1x bindings” is enabled.

but the diagnostics specifies some unsatisfied requirements.

openhab> bundle:diag 191
openHAB MPD Binding (191)

Status: Installed
Unsatisfied Requirements:
osgi.wiring.package; filter:="(osgi.wiring.package=org.openhab.core.binding)"
osgi.wiring.package; filter:="(osgi.wiring.package=org.openhab.core.events)"
osgi.wiring.package; filter:="(osgi.wiring.package=org.openhab.core.items)"
osgi.wiring.package; filter:="(osgi.wiring.package=org.openhab.core.library.items)"
osgi.wiring.package; filter:="(osgi.wiring.package=org.openhab.core.library.types)"
osgi.wiring.package; filter:="(osgi.wiring.package=org.openhab.core.types)"
osgi.wiring.package; filter:="(osgi.wiring.package=org.openhab.model.item.binding)"
Declarative Services

So it seems that openhab-runtime-compat1x it wasnt installed.

openhab> feature:list | grep comp
openhab-runtime-compat1x │ 2.5.0.M1 │ │ Uninstalled │ distro-2.5.0.M1 │ Compatibility layer for openHAB 1 add-ons

Once I installed it everything worked.

1 Like