[SOLVED] Openhab2 - Xiaomi Mi Gateway - does not respond

Tags: #<Tag:0x00007f616ec221e0> #<Tag:0x00007f616ec22078> #<Tag:0x00007f616ec21fb0>

Tried through putty got into the gateway but when I tested the port is still closed. But I did it not via SSH since via SSH I need a url path and port.

@rothm thanks for the lib! I’m just playing with it, trying to find some prettier “interface” between Gateway and outer world – MQTT works just fine for me, but I’m still thinking how to integrate into home automations different than OpenHUB. Will let you all know.

Hi all,
For who is having the device listening on port 9898/tcp, would it be possible to have copy of the binary file which is serving the service?

# netstat -naop

Then get the process which is serving the port on 9898.

Perfect would be a copy of the content of / and subfolders, btw the folder ‘/lumi/conf’ could be skipped, due it’s the path where device conf are saved (WiFi password, device key, …).
AFAYK, with the latest version there is no way to get the lan mode working. Maybe due it’s removed? @cadavre is more proof in detals :wink:
Just in case someone is available, I can share space and/or my mail for details!
Thanks!
Simon

Did someone tried the OTA update method?

1 Like

Hi
if ssh(dropbear) not work, check /etc/dropbear/*
if there is nothing in /etc/dropbear, it need generate key
use these two command to generate key

dropbearkey -t dss -f /etc/dropbear/dropbear_rsa_host_key
dropbearkey -t rsa -f /etc/dropbear/dropbear_dss_host_key

Can someone help me please? I soldered and followed the instructions. With putty (on Windows) I can correctly read the messages coming from the Gateway. But when I start typing (the command), nothing happens. The letters that I type don’t appear in the Putty window.

Done without any issue!!! OH is able to see the gateway!!!

Thanks!!!

Before you start typing the command, do you have to press a button first?

Because in this video (2.38) I hear the guy first pressing a button and then the # sign appears and then he starts typing. Which button?

It doesn’t matter actually. It’s just the console not displaying a “#”. I believe he pushed “Enter” and it popped up.

Unfortunately when I start typing, no letters appear. I only see the data coming from the gateway.

Thanks! pagm, that worked great

I had the same issue, check if the tx from the UART is propperly connected

Hey guys, i have bad soldering skills, and unluckily i unsoldered TX part of plate, it is possible to solder TX wire somewhere else or my gateway goes to trashcan???

Great Thank you (Y):smiley:

if someone failed and unsoldered part of tx/rx contact pad, so u can solder wires to 6/7 leg of wifi controller (that big thing under metal shiny plate)

Hi, Did anyone noticed that with the latest firmware upgrade (v. 1.6.2) and Aqara app version 1.5.3 after clicking several times the Gateway serial number a popup windows will show up with “For Developer” as title and requesting to input a URL and a MD5 Code.

Anyone has an idea if this is the so expected developer mode? Does anybody know how to take advantage of it?
I leave a screen capture of what I say here below:

Hi there, I successfully open port my second new gateway with UART mode. My question is now i able to do the firmware update? The new firmware is not close it again?

My old gateway (about one year old) is not closed after firmware update. (it not need to open it with UART, only just open it with the APP)

normally, new firmware don’t close the port

Another thing I discovered in the Aqara app, is that is you touch several times the model version of your gateway a popup will show saying “Entered test mode”

No idea what is this for but maybe we are near the “Developer mode” feature we request

Hello you could give more information on how to enable the ssh connection

Thank you