[SOLVED] Openhabian fails on RPi4..?

  • Platform information:
    • Hardware: RPi4 4GB
    • OS: Openhabian
    • openHAB version: 2.4
  • Issue of the topic: Failing install

Hi all,

Trying to to install openhabian on a new RPi4, but It keeps failing at this point:

2019-10-25_12:34:40_CEST [openHABian] Executing 'openhabian-setup.sh unattended'...
2019-10-25_12:34:40_CEST [openHABian] Checking for root privileges... OK
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Reading package lists...
2019-10-25_12:34:43_CEST [openHABian] Loading configuration file '/etc/openhabian.conf'... OK
2019-10-25_12:34:43_CEST [openHABian] Setting timezone based on IP geolocation... OK (Europe/Copenhagen)
2019-10-25_12:34:47_CEST [openHABian] Setting locale based on openhabian.conf... OK
2019-10-25_12:35:26_CEST [openHABian] Setting hostname of the base system... OK
2019-10-25_12:35:26_CEST [openHABian] Setting the GPU memory split down to 16MB for headless system... OK
2019-10-25_12:35:26_CEST [openHABian] Enabling Audio output... OK
2019-10-25_12:35:27_CEST [openHABian] Installing basic can't-be-wrong packages (screen, vim, ...)... OK
2019-10-25_12:35:29_CEST [openHABian] Installing additional needed packages... OK
2019-10-25_12:35:31_CEST [openHABian] Adding slightly tuned bash config files to system... OK
2019-10-25_12:35:31_CEST [openHABian] Adding slightly tuned vim config file to system... OK
2019-10-25_12:35:31_CEST [openHABian] Downloading and setting up FireMotD... OK
2019-10-25_12:36:26_CEST [openHABian] Installing Java Zulu 32-Bit OpenJDK...
gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error is not recoverable: exiting now
2019-10-25_12:36:30_CEST [openHABian] Initial setup exiting with an error!

[12:36:30] openhabian@openhab:/boot$

I have used the openhabian install many times on my Rpi 3 without issue.
Any ideas as to what I can try?
I have tried other SD cards with same issue.


Duped Topic.


Thanks for that! Worked for me:-)
Sorry about the duped topic - didn’t find it on my search.