[SOLVED] openHABian on Pine A64(+) regarding Java Problem

An openhabian image?

Yes, the one you posted earlier. openHAB ist running now but it isnt upgradable as it seems.

pub 4096R/A224060A 2015-07-25 [expired: 2019-07-25]
uid openHAB Bintray Repositories owner@openhab.org

As you may see, the repo for the updates was made invalid just before the new version with the dropped openHABian image (for the Pine A64) was released because its recommended to do it as I did before which is not working. Pretty dumb situation… xD

Update the repo manually:

wget -qO - ‘https://bintray.com/user/downloadSubjectPublicKey?username=openhab ’ | sudo apt-key add -

BTW that is a capital O not a 0 behind the q


So the key update worked and after that I was able to update to openHAB 2.5. Then I ran the openHABian config tool and did everything from there on (apply the improvements, install the log viewer etc.).
What I noticed is that the underlying OS is the Xenial Image so I will now try to write that to an SD-Card and do a clean install. :smiley:

But honestly im so curious to find out how the “recommended” way should work? I mean there definetly is a reason it is recommended and it should work but it doesnt… :thinking:
And I actually want to run the Armbian Buster Image with openHAB if someone can tell me how to fix it. :sweat_smile:

1 Like


It has been fixed in the latest release but as mentioned it’s not for Pine64.

Install Armbian Buster then manually install OH (not the openhabian image).

Thats what I did all along. Heres a Quote from the latest GitHub realese Post:

Pre-built PINE64 image has been dropped. Users are recommended to install an Armbian Buster system and manually apply openHABian explained here.

I did follow these instructions from the beginning and thats how I ended up with the error described in my initial post. And if they officially point to it I suspect it to work some kind of way.

Yeah maybe thats also worth a try. Let me try Xenial first and then i’ll try this :+1:

Try these instructions for manual install:

I use Openhab2 on Armbian (FriendlyElec Nanopi K1 / Allwinner H5, 2G, eMMC) without any issues. Use fixed version of armbian-config and it will work on any Armbian supported hardware. Tested.

There is indeed one bug here to prevent installation on generic Debian. OpenJDK8 is present on all Ubuntu variants, while its only present in Debian Stretch and Sid. Not in current stable build, Buster.


armbian-config install way now works out of the box after you update your Armbian. On Ubuntu flavour.

Thanks for your answer, the installation itself works now! I’m on Armbian Bionic with upgraded firmware and installed openHAB thru softy in armbian-config.

But I’ve got a new problem: If I navigate to [myIP]:8080 I get (even if I wait 30 minutes or longer)

Problem accessing /start/index.
Reason: Not Found

And if I take a look into the logs I find that the dashboard is stopped after like 20 sec. or so (I’ve tried to restart and reinstall serveral times, reflash the Image etc. with no success).

But I’ve a solution to this problem: uninstall the openhab2-addons package. It’s because openHAB thinks you preconfigured the UI packets (like PaperUI etc.) but if you don’t it hasn’t got anything to load.

You can also try the above by entering (altered for Linux apt installation)

sudo nano /etc/openhab2/services/addons.cfg

and altering the text file (I didn’t test this!).

If everything runs you can follow the openHABian instructions and start at “Apply Improvements” and do the things you wish. If you want the Samba shares follow the instructions here.

Thank you for your help @igorp and @H102 :hearts:

1 Like

Do you know when Debian Buster support is up again?

That problem will be solved by installing ZuluJDK like this is done on Openhabian https://github.com/openhab/openhabian/blob/master/functions/java-jre.bash I am already working on it but got stuck with a problem you just solved :slight_smile: I was already thinking to drop this idea and move to Docker. Where other problems are expected …

Also preparing official documentation how to install Openhab2 on any Armbian supported hardware.

That sounds great! If you need or want help I’m eager to support your awesome work :slight_smile:

If you got a moment, check / review before we send it upstream:

Looks good! I would add to either alter the addons.cfg file or edit the armbian installer script to not install openhab2-addons otherwise people will run into the same problem I’ve had this hole day :sweat_smile:

Now I’m setting up a new SD-Card and take a look if everything works as stated in the doc :slight_smile:

Another thing I would add is

sudo systemctl daemon-reload
sudo systemctl enable openhab2.service

to have openHAB start up automatically after a reboot.

Will script all this. Let me finish that Java install part, then let’s test again.

1 Like

Test this way:

git clone https://github.com/armbian/config
cd config

It must work on any Debian based machine, not just on Armbian. It test on amd64 VM and running it now on most tiny board I found on my desk. Zero Pi H3 with 512Mb memory:

So is just tested it on Armbian Bionic with the instructions to clone the GithHub repo and it works perfectly out of the box now! Thanks for implementing the fixes I found, now its just a matter of minutes to set up a openHAB instance :slight_smile:

It works now also out of the box on freshly updated system. I will try to improve things further - harden install, add addons, …

OS wise there is nothing to do (ZRAM exists in Armbian since early days and was anyway implemented in openHABian on my suggestions) … Any other 3rd party system application, add-on that should be added?

I sent a PR to the documentation https://github.com/openhab/openhab-docs/pull/1119 but don’t understand what is the problem or haw the docs must be prepared that its alright.


thanks @igorp !
I just installed openhab as described in your manual on the newest armbian buster image on my pine64.