[SOLVED] Openhabian update stops OWFS binding from working (as should be expected)

Hardware: Raspberry Pi B+
OS: openhabian
openHAB version: 2.40
I had OH2 all set up working with a dozen onewire sensors.
I worked on other programs on the Pi, and updated to the latest using openhabian-config. Then a day or two later I realized it was no longer getting temperatures. The Paper UI showed the onewire binding and items were there to add. but all my names were gone.
Finally went back and updated to the latest onewire binding using the karaf console option at https://janessa.me/esh/org.eclipse.smarthome.binding.onewire-0.10.0-SNAPSHOT-fi.jar and wahlah everything works again!
I think the openhabian-config update actually put an old binding back in.

onewire.things file like this with more things.
Bridge onewire:owserver:mybridge [network-address=“”]
Thing basic CPURoom [id=“28.3E0943982500”, refresh=60]
Channels: Type temperature-por-res : temperature [resolution=“9”]

The onewire.items file has one line for each item like this
Number:Temperature CPURoom “CPU Room [%.0f %unit%]” { channel=“onewire:basic:mybridge:CPURoom:temperature” }

The onewire.sitemap file like this
sitemap onewire label=“Main Menu”
Text item=CPURoom

And what exactly is not working any more?

Sorry it got posted before I was finished writing it.
Its all working, Just thought it might help some other newbie like me that didn’t realize using the openhab-config update to latest would put old stuff back in.

1 Like