[SOLVED] openHABian upgrade stops with error

I tried to upgrade my openHABian installation using openhabian-config. But the first time ever in two years, it fails with the following error:

[13:36:29] openhabian@openHABianPi:~$ sudo openhabian-config
2019-10-24_13:36:55_CEST [openHABian] Checking for root privileges... OK
OK:1 http://apt.pilight.org stable InRelease
OK:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Holen:3 http://archive.raspberrypi.org/debian stretch InRelease [25,4 kB]
Ign:4 https://dl.bintray.com/openhab/apt-repo2 stable InRelease
Holen:5 https://dl.bintray.com/openhab/apt-repo2 stable Release [6.051 B]
OK:5 https://dl.bintray.com/openhab/apt-repo2 stable Release
Es wurden 25,4 kB in 2 s geholt (12,6 kB/s).
Paketlisten werden gelesen... Fertig
2019-10-24_13:37:02_CEST [openHABian] Loading configuration file '/etc/openhabian.conf'... OK
2019-10-24_13:37:02_CEST [openHABian] openHABian configuration tool version: [master]v1.5-526(0986fff)
2019-10-24_13:37:02_CEST [openHABian] Checking for changes in origin... OK
2019-10-24_13:37:05_CEST [openHABian] Updating repositories and upgrading installed packages...
$ wget -O openhab-key.asc https://bintray.com/user/downloadSubjectPublicKey?username=openhab
--2019-10-24 13:37:05--  https://bintray.com/user/downloadSubjectPublicKey?username=openhab
Auflösen des Hostnamens »bintray.com (bintray.com)« … 75.126.118.184
Verbindungsaufbau zu bintray.com (bintray.com)|75.126.118.184|:443 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 200 OK
Länge: nicht spezifiziert [application/octet-stream]
Wird in »»openhab-key.asc«« gespeichert.

openhab-key.asc                                                 [ <=>                                                                                                                                     ]   3,14K  --.-KB/s    in 0s

2019-10-24 13:37:06 (6,24 MB/s) - »openhab-key.asc« gespeichert [3219]


$ apt-key add openhab-key.asc
OK

$ apt-get --yes upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

$ java_install_or_update
openjdk version "1.8.0_222"
OpenJDK Runtime Environment (Zulu8.40.0.178-CA-linux_aarch32hf) (build 1.8.0_222-b178)
OpenJDK Client VM (Zulu8.40.0.178-CA-linux_aarch32hf) (build 25.222-b178, mixed mode, Evaluation)

$ systemctl stop openhab2.service
openjdk version "1.8.0_222"
OpenJDK Runtime Environment (Zulu8.40.0.178-CA-linux_aarch32hf) (build 1.8.0_222-b178)
OpenJDK Client VM (Zulu8.40.0.178-CA-linux_aarch32hf) (build 25.222-b178, mixed mode, Evaluation)
2019-10-24_13:37:12_CEST [openHABian] Installing Java Zulu 32-Bit OpenJDK...
$ wget -nv -O /tmp/openhabian.1kJtN/zulu8.tar.gz
http://: Ungültiger Hostname.

gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error is not recoverable: exiting now
FAILED

Platform is a Raspberry PI3+ and it’s not the first time I did upgrades.
Seems like something is broken in the repository? (“hostname not resolvable”)

Is there anything I can do?

Thanks,
Boby

Another one, huh.


Did you upgrade openHABian first before trying to upgrade the whole system?

I just started openhabian-config, confirmed the the suggestion to update the openhabian-config tool and then used the “upgrade” function in the GUI of openhabian (like I did for approx two years now). So, I didn’t do anything else than ever. I’ll have a look at the topic you shared, thanks.

It looks like many people right now have a problem with the Zulu install step.
If read (2-3 posts) and heard from two friends about this issue.


Maybe @ThomDietrich is aware on this. Just to make sure I am tagging him.

Which would be the correct path I have to download the Zulu manually for a RPi3B+? Is it https://cdn.azul.com/zulu-embedded/bin/zulu8.40.0.178-ca-jdk1.8.0_222-linux_aarch64.tar.gz

Meanwhile I found out the correct file and path - but have no idea how this could make the upgrade working again,

Here’s the path for a Pi3B+:
https://cdn.azul.com/zulu-embedded/bin/zulu8.40.0.178-ca-jdk1.8.0_222-linux_aarch32hf.tar.gz

You never said you are on arch.
I assume this since your zulu url is linux_aarch.

edit:
wait wait I mixed something up. aarch is the architecture. Sorry my mistake.

I think that’s a good move - it seems the repository is no longer reachable via “http”, but only “https” - but the upgrade script of the openhabian-config seems to look for “http” - and then the download fails.
I’ll file a bug report on Githup

Found a workaround here: https://community.openhab.org/t/initial-setup-failed-on-raspi3b-due-to-a-java-zulu-path-error/70699/7?u=boby

To get the update going, only the editing of /opt/openhabian/functions/java-jre.bash was sufficient for me.
And: Yes, it’s a bug and it’s still open - so this workaround is the only way to circumvent the update.

1 Like