[SOLVED] Openhabianpi DEAD after clear-cache

  • Platform information:
    Rasperry pi 3 + RaZberry z-wave board
    • openHAB version: Openhabianpi image 2.4.0, recently upgraded to 2.5.0.M1
  • Issue of the topic: please be detailed explaining your issue
  • If logs where generated please post these here using code fences:

Openhab was acting more and more strange, yesterday I even had different channels showing in habmin and paper ui. So I decided to try clearing cache, as I had not done that after the upgrade.

Now it’s dead. It says service is running, but nothing in any of the logs, and nothing from debug output. I tried restarting services, also rebooting the pi, several times.

The logs at :9001 work, but there is nothing in the logs since the first reboot after clearing cache.
:8080 is dead
Logs are dead

Services seem to run fine, but there is absolutely zero happening in the logs, and again :8080 not responding. Help ! ?!

[11:17:44] openhabian@openHABianPi:~$ sudo openhab-cli start --debug

A systemd service configuration exists…
Use ‘sudo /bin/systemctl start openhab2.service’ to start an openHAB service
Launching an instance in this terminal…
Launching the openHAB runtime…
Listening for transport dt_socket at address: 5005

It’s really better to start openHAB2 via systemd:

sudo systemctl start openhab2.service

of course after stopping openHAB :wink:

Wouldn’t the same happen when I reboot the Pi? Because I’ve tried that several times with the same result.

I did as you said now, still dead.

I would suspect a potentially corrupt sad card. I had this happen to me. I rebuilt my system and all is well.

I don’t know how to test the sd card, but sometimes corruption is due to a power glitch vs bad hardware.

What is the output of openhab-cli info? Unfortunately if the behaviour has been getting worse without any input from you, it does sound like a failing SD card.

[15:02:02] openhabian@openHABianPi:~$ openhab-cli info

Version: 2.5.0.M1 (Build)

User: openhab (Active Process 1996)
User Groups: openhab tty dialout audio bluetooth gpio

Directories: Folder Name | Path | User:Group
----------- | ---- | ----------
OPENHAB_HOME | /usr/share/openhab2 | openhab:openhab
OPENHAB_RUNTIME | /usr/share/openhab2/runtime | openhab:openhab
OPENHAB_USERDATA | /var/lib/openhab2 | openhab:openhabian
OPENHAB_CONF | /etc/openhab2 | openhab:openhabian
OPENHAB_LOGDIR | /var/log/openhab2 | openhab:openhabian
OPENHAB_BACKUPS | /var/lib/openhab2/backups | openhab:openhabian


Now the UI menu suddenly works. But if I click any UI’s, there is no connection.

Corrupt/unwriteable SD card could perhaps explain the lack of logs.

But wouln’t an SD card with errors show something in the logs? Why would the whole of Openhab suddenly freeze after I clear the cache?

How can I revert to 2.4.0, I said yes to make a backup at some point in the upgrade process.

I downgraded to 2.4.0. It lives!

Great, back to the problems that caused me to upgrade. We’ll get back to that in another thread, thanks for all your help!

You never wrote about an upgrade, only about clear-cache… :wink:

Line 3 of the original post :wink:

Ah! :smiley: