[SOLVED] OpenWebNet binding on OH2 - thermostat heating channel not updating

Tags: #<Tag:0x00007f2fbbb13748>

Hi Guys,
I’m using OpenWebNet 2.4.0 provided by Massi with OH2 2.3.0 on a Raspberry PI. I have 8 thermostats and I’m able to get the “heating” channel updated only for 3 of them. There seem to be no difference in how I defined things and items but only 3 of them update the status of “heating”, for the other 5 I get a NULL status.

Here is my conf. Things:

Bridge openwebnet:bus_gateway:OWNBridge "MyHomeServer1" [ host="192.168.Y.YYY", passwd="ZZZZZZZ" ] {
    bus_thermostat      ThermoBagnoP1       "Termostato Bagno P1"  [ where="7"]
    bus_thermostat      ThermoBagnoPT       "Termostato Bagno PT"  [ where="2"]
    bus_thermostat      ThermoCamera        "Termostato Camera"  [ where="4"]
    bus_thermostat      ThermoGarage        "Termostato Garage"  [ where="3"]
    bus_thermostat      ThermoJordi         "Termostato Jordi"  [ where="5"]
    bus_thermostat      ThermoMarco         "Termostato Marco"  [ where="6"]
    bus_thermostat      ThermoSoggiorno     "Termostato Soggiorno"  [ where="1"]
    bus_thermostat      ThermoStudio        "Termostato Studio"  [ where="8"]
}

Items:

Switch ThermoBagnoP1_Heating   { channel="openwebnet:bus_thermostat:OWNBridge:ThermoBagnoP1:heating" }
Switch ThermoBagnoPT_Heating   { channel="openwebnet:bus_thermostat:OWNBridge:ThermoBagnoPT:heating" }
Switch ThermoCamera_Heating    { channel="openwebnet:bus_thermostat:OWNBridge:ThermoCamera:heating" }
Switch ThermoGarage_Heating    { channel="openwebnet:bus_thermostat:OWNBridge:ThermoGarage:heating" }
Switch ThermoJordi_Heating     { channel="openwebnet:bus_thermostat:OWNBridge:ThermoJordi:heating" }
Switch ThermoMarco_Heating     { channel="openwebnet:bus_thermostat:OWNBridge:ThermoMarco:heating" }
Switch ThermoSoggiorno_Heating { channel="openwebnet:bus_thermostat:OWNBridge:ThermoSoggiorno:heating" }
Switch ThermoStudio_Heating    { channel="openwebnet:bus_thermostat:OWNBridge:ThermoStudio:heating" }

I checked the status also via REST APIs and I get “OFF” for these 3 items:

ThermoSoggiorno_Heating
ThermoBagnoPT_Heating
ThermoGarage_Heating

and NULL for the others.

Can you please help?

thanks.

Please use the code fences
You can edit your post and add them in

@massi can you help?

Update.

  1. The “Studio” thermostat is now below target temperature and switched the valve to ON but the associated item ThermoStudio_Heating is still showing NULL. The thing works correctly as I can read the temperature and target temperature associated to the thing.
  2. heating property should be read-only but tried to write a state to it via REST APIs and I can do it, is this correct?

thanks.

Hi Luciano,
the configuration is of course correct since it’s the same for all thermos.
there may be a problem if the heating actuators of the 5 thermostats are registered under a different number: I assume in the binding the heating actuator its numbered “1”. Maybe you can check this in your virtual configurator.
To be sure this is the problem, I would need some logs: refer to the binding README to how to set your log file to DEBUG, then make sure one of the 5 thermostats goes below target temp, then make it start heating, then send me the openhab.log file and tell me which is the address of the thermostat you used for the test.

the channel is defined as “read only”:

<channel-type id="heating"  advanced="true">
		<item-type>Switch</item-type>
		<label>Heating Is</label>
		<description>Heating is active (read only)</description>
		<state readOnly="true" />
	</channel-type>

and most importantly there is absolutely no code in my binding that is able to change the heating channel using a command coming from OH2.
After you changed it via REST API did you see the changed value in PaperUI ?
Did you check the new state of the channel again using the API ?

bye
Massi

Hi Massi

there may be a problem if the heating actuators of the 5 thermostats are registered under a different number: I assume in the binding the heating actuator its numbered “1”. Maybe you can check this in your virtual configurator.

In fact the 5 associated actuators were not numbered as “1” (which doesn’t make sense). I fixed the cfg and now testing. THANKS.

After you changed it via REST API did you see the changed value in PaperUI ?
Did you check the new state of the channel again using the API ?

I tried to post via APIs the value ON and the response was:

  • I see ON in PaperUI
  • I GET ON from APIs
  • The ON value is reflected in my influxDB as it is persisted on everyChange
  • The thermostat (the device) doesn’t switch to ON

So it seems the hardware is not affected, but the sw object is. I think I can live with this :slight_smile:

thanks again.
L

good, let me know because if this works, I will update the readme as a solution. others have reported this in the past.

this is very weird behavior from OH2, it seems the OH2 accepts the status update even if the binding does not update the status. I will do some more testing about this to make sure is not an error on my binding.

bye
m

I confirm it works fine now.

@llegovich, can you write here 2 lines of how did you modify the coniguration in you system to check and modify that actuators are numbered correctly ?
O will suggest this in the binding README
bye
M

In the readme I would write the following:

To ensure the actuator is set up correctly, for each thermostat follow the steps below:
1. open MyHome_Suite (setup tool provided by bTicino/Legrand)
2. select the thermostat, this brings you to the thermostat configuration panel
3. select the first tab "Plant settings" and in the "Actuators section" check if the first actuator listed has been numbered with N° 1. This will be the actuator which state will be returned by the binding through the channel "heating".
4. if the actuator is numbered N° 1 then STOP here
5. if it is not numbered N° 1 then you have to set it to N°1
6. find the actuator device corresponsing to the same zone as that of the thermostat and set the "Device number" property to 1

Please feel free to cut/re-phrase as you wish.
Not easy reading without screenshots. If anyone asks for further details I’m happy to write a guide with screenshots.

ciao.

Write anyway. It might help someone one day.

Hi
I added some notes about the actuator configuration in the README.

Regarding th other issue: is happening same to me.

To avoid this, the binding should probably have to change its update policy , something which is being introduced in OH 2.4.0 now.

Can you submit a new issue about that point , trying to explain the problem you face?

Bye
Massi