[SOLVED] Osram Lightify with OH2

I’m also trying to get the Lightify workaround to work on OH2, but I’m having a different problem.

Everything works well when I run the Python script from the command line, but I get this error when I try to have the rule run the script with executeCommandLine.

Here’s the error shows up in the log. Does this make sense to anyone?

2017-02-23 19:09:08.009 [INFO ] [.LIGHTIFY RULE: updateLightifyDevice] - command =python@@/etc/openhab2/scripts/mylightify.py@@–bridge@@“xxx.xxx.xxx.xxx”@@–device@@Room1@@–onoff@@1command results = Traceback (most recent call last):
File “/etc/openhab2/scripts/mylightify.py”, line 29, in
lightify = Lightify(args.bridge)
File “/usr/local/lib/python2.7/dist-packages/lightify/init.py”, line 198, in init
self.__sock.connect((host, PORT))
File “/usr/lib/python2.7/socket.py”, line 224, in meth
return getattr(self._sock,name)(*args)
socket.gaierror: [Errno -2] Name or service not known

I was using the Osram (lightify) binding from Mike Jagdis and has been working good for a while now I had to do a mandatory update to firmware 1.7 and now I have uninitialized binding. Any ideas to resolve this?