[SOLVED] P. ex. MQTT Installation of the Binding


after hours and hours of debugging i got my mosquitto working. But now i tried to install the binding…

2018-05-27 01:21:14.558 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-mqtt1': Error:
	Error downloading mvn:org.openhab.io/org.openhab.io.transport.mqtt/1.11.0
	Error downloading mvn:org.openhab.binding/org.openhab.binding.mqtt/1.11.0 

Any idea?!

I am running the latest 2.3.0…

No bindings can be installed… dns etc. works fine.


Accept legacy bindings. MQTT is a 1.x binding compatible with 2.x

No, still does not work.
In paper ui the installation wheel is rotating and rotating… and in the logfiles i ll find the error of downloading mvn:org…

I think its an issue with 2.3. …

What OS are you running?

just a quick note: I think that this will apply (have effect for MQTT1) when the MQTT v2 will be released (e.g. KNX1/2, Exec1/2, etc)
From what I see in my systems (OH 2.3 RC1 & RC2), I don’t have MQTT2 available yet.

OH2.3 RC1, RC2 or another build?

For the mvn: I don’t know what could the problem…

I just tested the installation of the MQTT1 binding on a test OH2.3RC2 system and it worked fine (downloaded it online and installed without problems)

Make sure that your host has proper internet connectivity.

Ubuntu 16.04 with all updates/upgrades.

Hah… solved it. Found this:

Thanks everyone.