[solved]PaperUI not showing bindings anymore(Extensions menu is missing)

I updated my system (raspberry2) today. Openhab2 is running with no problems, however the PaperUI isn’t showing the Tab with all bindings, where you could select to install them?
Is this gone on purpose or is there a problem in my setup?

Can you clean the browser cache and retry?

Done that, no change.

I’ve just tried build 253 and all looks good there (I assume you mean the “Extensions” menu entry, right?).

Are there any errors in the Javascript console?

Since “Extensions” isn’t showing on my PaperUI, that’S the name of what is missing.
If the Javascript console is the same as the one I opened with “ssh karaf@ -p 8101”, then I don’t see any errors beside the standard ones at the beginning ("… Circular reference detected, getService returning null…" and one relating to a rule during early startup).

This does not sound like build 253 to me - the circular dependency message should not be there anymore, this has been fixed…

OK, since I got some help to install OH2 ending of last month I’ll have to have deeper look into that myself.
That will take some time.

Whatelse, beside the openhab-distro-2.0.0.b2, do I have to check/reinstall/update?

You should take a complete new distro from https://openhab.ci.cloudbees.com/job/openHAB-Distribution/lastSuccessfulBuild/artifact/distributions/openhab-offline/target/openhab-offline-2.0.0-SNAPSHOT.zip.

Installed that, however no change??? Even the Error " Circular reference detected, getService returning null" is still in there?
I must be doing something wrong.

However that reminds of a problem I had with channels of discovered things not showing all the time. That went away after a FritzBox was also present. However that might not been the reason.

I did take a deeper look into my system. The “feature:list” did show jetty not installed, maybe that is because I did use another server before OH2 got installed? Could that be a/the reason?

It gets even more weird!
I’m using Firefox (45.0.2) as a browser, when selecting as Web-Style “No Style” i can select the “Extension” menu item. Changing back to the Standard-Style, the menu item “Extension” is still missing, however I’m on the Extension page, the submenus for “Bindings, User Interfaces …” are visible. See attached screen shot.

…and now it is working again.
After a try to install a binding (since I got the Bindings menu displayed again) the Extensions menu reapeared!
May it stay that way (keeping fingers crossed)
Some more ideas on the reason:
The first hint from Kai Kreuzer was in the correct direction, and most will believe that it pointed to the only reason.
I did check for the missing “extensions” menu (while it was not shown on my main browser) with Chrome and IE on the Windows machine (both never user before [nothing cached])and on an android device. All with the same result. Especially when checking on Chrome and IE I saw a PaperUI not really responsive and showing (initially) false text (maybe the Name of the displayed field?).
However, having seen the PaperUI “stumbeling” on the update on some menu-items (taking a bit longer, initially not showing the correct text…) I do believe it could to be related to problems parsing the .Items and .Sitmap files.

I had a very similar experience that I will share hoping it might help someone else.

I was using the stable OpenHAB 2.0 distro. Decided to switch to the snapshot release 2.1.0, so I followed the steps on the openhab documentation site (including the backup and restore of my config files). After upgrading, all of the addons in the paper UI were gone. I still had my MQTT binding working, but couldn’t see it in the paper UI either. Tried cleaning the cache on my browser and also using another browsers (chrome, IE and Edge), but the result was always the same. I then decided to reinstall the snapshot distro, but without restoring my configurations. All of the addons were there in the paper UI, so I wrote my sitempaps, items and transformations again from scratch and that solved it.

Also i have had this same issue. Also in habmin ui the extensions showed an error. In both times i had had this issue i solved it by uninstalling a addon that i was having problems with. First time it was RFX and after i reinstalled it the addons menu kept working. And just now i had it with the Samsung TV.

i uninstalled by conencting to the karaf console

  • bundle:list
  • bundle:uninstall xxx

I just had a simular issue with OpenHAB 2.2.0.
I was playing around with the user interfaces, and wanted to check out the ‘Home Builder’, and the ‘CometVisu Backend’). Once I installed these over the addon menu in PaperUI, the addon menu dissapeared.

I could easily enter the ‘menu’ by adding /paperui/index.html#/extensions after my server ip.
Once I remove the user Interface for CometVisu Backend, the menu is back.

I have the same issue!

After installing CometVisu the extensions menue is away :-/

When I deinstall it, it´s working again.

Openhab 2.3.0

Hi @stolly82
How did you uninstall the CometVisu Backend without the menu?
I have the same issue.

When no GUI is available you may use the console:



I deinstalled CometVisu complete, it wasn´t working really good, that´s why.