[SOLVED] Param range of FGS222 wrong

Once the binding is updated, if you’re running the snapshot version of the runtime then to update to the latest version you just uninstall and reinstall the binding and it will pick up the latest version. If you’re running the release version then it’s somewhat more complicated so I’d recommend using the snapshot :wink:

I don’t know what I use. I installed OH2 on my rpi3 via netinstall

It depends on what repositories you configured I think (as per the docs you can use the standard or the snapshot install).

I noticed you registered on the database site - I’ve updated your access…

Chris, thanks so far for your support.

Z-way-server was instable, but much easier to run. That’s why I am totally confused.

How can I find out if it was the snapshot? I installed the zwave binding via paper ui …

What happens when I reinstall the binding? Will my controller loose all devices so that I would have to include them again? Does OH2 loose all its things?

If you log on to Karaf console (see the docs on how to do this) then you can see the versions with the list command. If you take a look at the docs, I think it is down to what repositories you added to your system.

Ummm - it is restarted just the same as if you restart OH.



Ok, great, I’ll come back after looking into karaf. And sorry for these newbie questions

I guess I am still not where you wanted to guide me to, but karaf tells me that the whole openHAB stuff including zwave binding is v2.0.0, all the Eclipse stuff is 0.9.0.b4. There’s lots of other stuff of course.

I had a look into the documention but did not find any version history.

What I downloaded and installed was https://github.com/openhab/openhabian/releases/download/v1.2/openhabianpi-ua-netinst-20170317-gitbd31755f-crc88a5ae46.img

Hi Chris,
updated the value ranges in your db. After editing, I sent the new data and requested review

1 Like

Thanks - I’ll take a look a bit later.

Hi Chris,
did you have a look into my changes?
What do I have to do next?

Yes - all approved and completed a few days ago.

You need to update to the latest snapshot.

I gues the following article descibes how I should do the update:


Hm, I did the following:
added the openHAB 2 Unstable Repository to my systems apt sources list
I stopped the openhab2 service
sudo apt-get update
sudo apt-get upgrade
I started the service again
I uninstalled and re-installed the zwave binding

Almost everything seems to work fine, but I can’t see any of the changes that I did in your db. Have a look at the screenshots: Zwave version is 2.1.0.SNAPSHOT, but there is still the wrong explanation text for param 4 and the value range ist still 0 - 255. Why?

The most common issue with this sort of thing is that you aren’t really running the latest snapshot, or maybe the package you are using hasn’t been updated recently.

Thanks for the hint, Chris.
The snapshot “openhab.jfrog.io/openhab/openhab-linuxpkg unstable main” hasn’t been updates since 3 days. But as it was newed this morning, I upgraded again and now everything works fine.

Thanks very much for your help. I learned a lot about OH!

Hi Chris,
though the 2.1.0-snapshot did the job for my changes in your db, I want to go back to the official release, because the snapshot doesn’t seem to work with caldav (see: Caldav not working with OH2)

Can you describe how I can benefit from the db-changes within the official relesse?

You need to continue to use the snapshot binding - there’s no way to use a new database with an old binding as ESH is designed to load the XML files only from the binding.

Hi Chris,
Ok. I have made the changes to my device as I need them. What happens if I go back to the official release and do not touch the device parameter any more?

This is fine - the binding won’t mind if it’s jut the range that’s wrong, so you can switch back to the old one if you prefer. the

Ok, fine, thx!