[SOLVED] Persistence TimeZone-Problem after restart

Hello,

today after a restart of openhab i get the message below…

The server time zone value ‘CEST’ is unrecognized or represents more than one time zone. You must configure either the server or JDBC driver (via the serverTimezone configuration property) to use a more specifc time zone value if you want to utilize time zone support.

I dont know what has happened…any idea??

Thank you!!

Hi izakstern,

had the same issue after a reboot
I used this tutorial and changed the time zone configuration for my MariaDB-Server from “SYSTEM” to “+02:00”. The only difference was, that I needed to change the file /etc/mysql/my.cnf. I just added the line as given in the tutorial, did a restart and Openhab (and persistence) works as expected.

The only thing is- I assume- I need to do that change again with the next change to “Winter Time” to ammend then to “+01:00”. Anyone an idea how to fix this properly?

Cheers
Matthias.

P.S.: what happened is that we changed just this weekend from CET (Central European Time) to CEST (Central European SUMMER Time). So we changed from Winter Time to Summer Time and looks like that JDBC Driver or MariaDB or whatever only understands CET??? Time to get rid of the time changes… :wink:

Hi Matze,

thank you for your reply. I solved it now that way:
In the mysql.cnf i added to the mysql connection string the TimeZone Europe/Berlin.

–> jdbc:mysql://:/?serverTimezone=Europe/Berlin

The timezone-string “Europe/Berlin” is the string which the PaperUI shows me. Server-Timezone is still “CEST”.

3 Likes

Thanks. That seemed to solve it for me, too.

I added

url=jdbc:mysql://127.0.0.1:3306/openhab?serverTimezone=Europe/Berlin

to the mysql.cfg.
Now it works.

See the post
https://community.openhab.org/t/solved-after-reboot-no-connection-to-mysql-database/70023/5

2 Likes

Just a minor addition to this: If you have more than one option you need to add to your URL, the separator is “&”.

In my case:
url=jdbc:mysql://host:3306/OpenHAB?useSSL=false&serverTimezone=Europe/Stockholm

This may be obvious to everyone else, but it wasn’t to me. :upside_down_face: :face_with_symbols_over_mouth:

1 Like