[SOLVED] Popp Strike Lock Control Issue

I just tried to include the Popp Strike Lock Control. A am using the 2.3.0 snapshot version of openhab and have a weired problem with this device. First it is found by the z-wave binding but the binding throws the following errors :

2018-05-11 21:21:58.719 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - NODE 63: setupNetworkKey useSchemeZero=false

2018-05-11 21:22:25.326 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - NODE 63: setupNetworkKey useSchemeZero=true

2018-05-11 21:22:25.329 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - NODE 63: Using Scheme0 Network Key for Key Exchange since we are in inclusion mode.

2018-05-11 21:22:25.645 [INFO ] [curityCommandClassWithInitialization] - NODE 63: Setting Network Key to real key after SECURITY_NETWORK_KEY_SET

2018-05-11 21:22:25.649 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - NODE 63: setupNetworkKey useSchemeZero=false

2018-05-11 21:22:25.782 [ERROR] [col.security.ZWaveSecureNonceTracker] - NODE 63: SECURITY_ERROR Device message contained nonce that is unknown to us, id=-110.

2018-05-11 21:22:26.026 [WARN ] [mmandclass.ZWaveSecurityCommandClass] - NODE 63: payloadQueue was empty, returning!

What does that

…message contained nonce that is unknown to us, id=-110… mean.

Haven’t seen that before.

Maybe someone could give advice for that kind of issue. I woke the device up several times and tried to see anything in the log, but unfortunatelly without success.

To include secure devices you need to upgrade to the development/security version of the zwave binding:

1 Like

Actually I read about that security thing, but I was wondering why my keyfob was working, which should be a security device as well. But the keyfob device works like a charm.

All devices can be included without security (except the locks, I think [I don 't have any])
That’s why it works with the stable or snapshot release.
Take a look at HABmin and check the attributes section: locks should have at “Using security” a green checkmark:

Thanks for your reply. So I will give the development version a try. In my current snapshot version there’s just a question mark in habmin at the security class row. My guess is, that it is just not offered by the snapshot.