[SOLVED] Problem getting UPB binding to work on raspberry pi

I have a fresh install of openhab installed on a raspberry pi 3. When I attempt to send a upb command I receive this error message

org.openhab.binding.upb:1.13.0 (210)[org.openhab.binding.upb.binding(12)] : The activate method has thrown an exception
java.lang.RuntimeException: Failed to open serial port.

I have verified that the openhab user is in the appropriate groups to use serial device

pi@raspberrypi:/var/log/openhab2 $ groups openhab
openhab : openhab tty dialout audio bluetooth

pi@raspberrypi:/dev $ ls -l | grep USB
crw-rw---- 1 root dialout 188, 0 Oct 5 12:25 ttyUSB0

pi@raspberrypi:/dev/serial/by-id $ ls -l usb-Keyspan__a_division_of_InnoSys_Inc._Keyspan_USA-19H-if00-port0
lrwxrwxrwx 1 root root 13 Oct 5 12:25 usb-Keyspan__a_division_of_InnoSys_Inc._Keyspan_USA-19H-if00-port0 -> …/…/ttyUSB0
pi@raspberrypi:/dev/serial/by-id $

I have also added the extra java options for serial device

/etc/default/openhab2 file

UPB binding config file


The UPB modem port. Valid values are e.g. COM1 for Windows and /dev/ttyS0 or

/dev/ttyUSB0 for Linux (required)


UPB Netword ID (required, must be a value between 0 and 255, inclusive)


That is an old OH1 binding. I noticed this:

This binding requires the use of a UPB PIM or power-line modem.

It appears you have a serial to USB converter. Perhaps that is the issue.

The UPB PIM is connected to the usb serial device /dev/ttyUSB0

Have you tried simply:


I changed the port value to /dev/ttyUSB0 and now I do not see errors however the upb devices are not turning on or off. I see entries such as 2019-10-05 16:44:24.470 [vent.ItemStateChangedEvent] - XMAS_Appliance changed from ON to OFF in the log file but the upb devices are not changing. I can control them with the same serial adapter using Upstart. In upstart I have changed the UPB password to nothing which shows as 0000 but I can’t find reference to the UPB password in the upb binding documentation. I originally used the by-id serial value because the tty name value changes

Fixed the issue by creating a symlink for the serial device by configuring the /etc/udev/rules.d/99-usb-serial.rules file. I also had to configure the pi account to be a member of the dialout and tty groups because I did a manual install of OpenHAB on the raspberry pi