[SOLVED] Problem in wifi connection

Dear Community,

The openhab was running correctly on raspberry pi 3 b+, with wifi configuration.
Now when plug network cable the connection will work, however wifi connection stopped working, and when the system booting it hangs with set of “waiting up” messages, then continue but without wifi connection!

And the contents of /etc/network/interfaces:

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

Can you help me to solve this problem.

Hello, did you set the correct ‘System Locale’ in the openHABian Configruation Tool?
Also you can set the Wifi setup there.
See also:

I put it “AE” as here it is United Arab Emirates. but still the problem. and bu they way it was working!

Please mark the thread as solved, thanks

but it doesnt!

Here when I plug network cable: I can see that both ethernet and wifi have ip address, subnet. however when I unplug the network cable. the connection lost (wifi doesnt make the connection)!


Thank you guys for your interesting,
the problem had solved by removing the “ip” definition in the “/boot/cmdline.txt”

Actually I add thip ip to make my laptop screen & keyboard a raspberry pi ones