[SOLVED] Problem to run TTS ( Amazon Echo Control Binding ) via rule

I am new to openhab and started a few days ago.
I am trying to run TTS using Amazon Echo Control Binding.
Received possive result via PaperUI. Alexa says the text I entered in the UI.
Next I tried to do this via rule resp. command line but this failed.
No error message at command line nor in the event log or openhab2 log.

I am using 2…5.0 M1 release.
command line: WolfgangsEchoPlus_Speak.sendCommand(“a b c d”)

Item is configured:
openhab> smarthome:items list |grep Speak
WolfgangsEchoPlus_SpeakVolume (Type=DimmerItem, State=0, Label=Speak volume, Category=null)
WolfgangsEchoPlus_Speak (Type=StringItem, State=, Label=Speak, Category=null)

What do I need to do to get it running resp. to debug it ?


Are these Items linked to the proper Channels on the Echo Thing?

I thought that these links ( with were created by using the UI ) must be correct as they work via the UI.

openhab> smarthome:links list| grep Wolf
WolfgangsEchoPlus_LastVoiceCommand -> amazonechocontrol:echo:<Account ID>:<Echo-Plus-Serial-Number-Here>:lastVoiceCommand
WolfgangsEchoPlus_Speak -> amazonechocontrol:echo:<Account ID>:<Echo-Plus-Serial-Number-Here>:textToSpeech
WolfgangsEchoPlus_SpeakVolume -> amazonechocontrol:echo:<Account ID>:<Echo-Plus-Serial-Number-Here>:textToSpeechVolume

In http://cubietruck:8080/amazonechocontrol/<Account ID>/ids/?serialNumber=<Echo-Plus-Serial-Number-Here> I see channel bluetootMAC, Channel amazonMusicPlayListId, Channel playAlarmSound, Channel musicProviderId but no further channel.

What do you mean by commandline?

With command line I mean the openhab console as it’s described here: https://www.openhab.org/docs/administration/console.html

The command I used is: WolfgangsEchoPlus_Speak.sendCommand(“a b c d”)

That is how a command is sent to an item in a DSL rule. I haven’t done this using the karaf console, but according to the documentation here, the correct way would be:

openhab> smarthome:send WolfgangsEchoPlus_Speak 'a b c d'

There are several ways one can create the links and you didn’t mention how they are linked. So I had to ask the obvious.

@scottk: thanks that is working.
@rlkoshak: you are absolutely right. rereading my previous mail I see that I did not explicitly mentioned it.

Just tested also the rule is working now. I would like to thank you for your feedback.