Solved, Problem with DSMR Binding

Hello all,

I get the following error message when using the gas part of the binding.

22:19:57.620 [WARN ] [smr.internal.messages.OBISMsgFactory] - Received OBIS unknown message:0-1:24.1.0
22:19:57.624 [WARN ] [internal.p1telegram.P1TelegramParser] - Failed to parse:OBISDataLine [OBIS id:0-1:24.1.0, obis values:[003]
22:19:57.631 [WARN ] [smr.internal.messages.OBISMsgFactory] - Received OBIS unknown message:0-1:96.1.0
22:19:57.633 [WARN ] [internal.p1telegram.P1TelegramParser] - Failed to parse:OBISDataLine [OBIS id:0-1:96.1.0, obis values:[4730303332353631323339363438373135]
22:19:57.636 [WARN ] [smr.internal.messages.OBISMsgFactory] - Received OBIS unknown message:0-1:24.2.1
22:19:57.640 [WARN ] [internal.p1telegram.P1TelegramParser] - Failed to parse:OBISDataLine [OBIS id:0-1:24.2.1, obis values:[161220220000W, 00515.354*m3]

what does this mean?? The correct gas reading (00515.354*m3) is there, but not correct parsed?

P.s i’m using Openhab 2, trying :slight_smile:

Regards Bert

Could you check whether the new version of the binding as mentioned in works better?

Are you running running the latest snapshot or latest beta release?

Could both of you also enable debug logging for the package org.openhab.binding.dsmr

There is at least one change that was not in 1.8.3 and is included in the latest snapshot, and the value happens to be logged at debug level.

I have the same issue and I’m using the latest snapshot.

Can you provide some debug logging and do an attempt with this snapshot version of binding:

This version works for me! Gas is being read fine. Thanks. Do you still need my logfile?

If it works not, good luck with it!

Sorry, i was “out of the office” but the last update solved also my “problem”