[SOLVED] Problem with fresh Openhab 2.5 / Zigbee / ETRX357USB-LRS / Device Pairing


today I did a fresh install of openhab 2.5 (openhabian) with a newly bought Telegesis ETRX357USB-LRS Dongle.

Unfortunately, I am not successfull in paring devices with the zigbee binding:

  • Things are being discovered as “Unknown zigbee device xyz”. Device information is not being completed during discovery (tried multiple times).
  • After adding the Devices as Things anyway, the stay in status “OFFLINE / Node has not completed discovery”.

I tried this with a Osram Smart Plug wich 100% worked in the past with OpenHAB 2.4 / CC2531. Here is the debug log of my attempt to pair this device (mac 7CB03EAA00B286F8): openhab.log (532.9 KB)

Maybe this is related to https://community.openhab.org/t/zigbee-problems-after-update-to-2-5-m4/85511?

For the next 4-5 days I will not have access to the system, but when I’m back I’ll be happy to provide more information if necessary.

Thank you!

Edit: I tried two joining modes: “Allow all joins” and “Allow only secure joining”

What version?

This device is used quite extensively by German Telecom and I think quite a few people here who have been using it for quite some time. I don’t think there are any issues reported.

This issue is a problem with the serial port configuration.

In the log I see -:

2019-12-21 12:21:32.164 [DEBUG] [gesis.internal.TelegesisFrameHandler] - TX Telegesis Data:AT+SENDUCASTB:02,0000,00,00,0000,0031
2019-12-21 12:21:32.191 [DEBUG] [gesis.internal.TelegesisFrameHandler] - RX Telegesis Data:ERROR:02

This error means that the command to send data (ie SENDUCASTB) is not supported. Clearly, this is a problem which makes me think you have an old version of the firmware (possibly R308).

As always, thank you for your fast reply.

Should be R309 according to the description. I bought this one: https://www.mouser.de/ProductDetail/Silicon-Labs/ETRX357USB-LRS?qs=8HqIXBaaO6wqBnOWG1Brjg%3D%3D

How can I verify this?

It should show up in PaperUI properties.

It only shows:

Anywhere else?

Hmmm - maybe I only implemented this for things, and not coordinators. It will be logged in the log on startup though.

The Osram motion sensor has been marked as NOT working with the Telegesis stick, it’s probably the same issue with the smart plug. My Innr SP 120 smart plug also didn’t work with the Telegesis stick.

@chris If you have some time during the x-mas holidays it would be great if you could take another look at flashing the Telegesis stick with the Ember firmware. The stick is still easy to get at a reasonable price and converting it to an Ember stick would be a great option.

Ok, I’ll see what I can do. I hope to look at some of the binding issues such as OTA console, but need to get the latest ZSS libs merged first…

1 Like

I just checked the code, and it is already there along with a load of other properties. The fact that there are no properties showing here probably indicates a wider issue.

During startup, I also can’t find a version:

2019-12-21 13:42:10.977 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - Starting ZigBeeDiscoveryService
2019-12-21 13:42:11.727 [DEBUG] [e.telegesis.handler.TelegesisHandler] - Initializing ZigBee Telegesis serial bridge handler.
2019-12-21 13:42:11.729 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Initializing ZigBee network [zigbee:coordinator_telegesis:06001B7F].
2019-12-21 13:42:11.732 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Channel 11
2019-12-21 13:42:11.734 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - PANID 34332
2019-12-21 13:42:11.737 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - EPANID 0B957000934ED82E
2019-12-21 13:42:11.746 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Network Key F8C0F0CFE0998611965BF2397A24752E
2019-12-21 13:42:11.749 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Link Key 5A6967426565416C6C69616E63653039
2019-12-21 13:42:11.752 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Config: zigbee_initialise found, initializeNetwork=false
2019-12-21 13:42:11.754 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Network Key String F8C0F0CFE0998611965BF2397A24752E
2019-12-21 13:42:11.759 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Network key final array F8C0F0CFE0998611965BF2397A24752E
2019-12-21 13:42:11.763 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Link Key String 5A6967426565416C6C69616E63653039
2019-12-21 13:42:11.767 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Link key final array 5A6967426565416C6C69616E63653039
2019-12-21 13:42:11.939 [DEBUG] [e.telegesis.handler.TelegesisHandler] - ZigBee Telegesis Coordinator opening Port:'/dev/ttyUSB0' PAN:861c, EPAN:0B957000934ED82E, Channel:11
2019-12-21 13:42:11.990 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Scheduling ZigBee start
2019-12-21 13:42:12.132 [DEBUG] [ng.zigbee.handler.ZigBeeThingHandler] - 7CB03EAA00B286F8: Initializing ZigBee thing handler zigbee:device:06001B7F:7cb03eaa00b286f8
2019-12-21 13:42:12.165 [DEBUG] [ng.zigbee.handler.ZigBeeThingHandler] - 7CB03EAA00B286F8: Coordinator status changed to UNKNOWN.
2019-12-21 13:42:12.171 [DEBUG] [ng.zigbee.handler.ZigBeeThingHandler] - 7CB03EAA00B286F8: Coordinator is unknown or not online.
2019-12-21 13:42:12.776 [INFO ] [roker.internal.EmbeddedBrokerService] - Broker persistence file: mqttembedded.bin
2019-12-21 13:42:12.997 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - ZigBee network starting
2019-12-21 13:42:13.000 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Initialising ZigBee coordinator
2019-12-21 13:42:13.069 [DEBUG] [e.transaction.ZigBeeTransactionQueue] - Default: Set profile to ZigBeeTransactionProfile [maxOutstandingTransactions=2, interTransactionDelay=50, maxRetries=2]
2019-12-21 13:42:13.073 [DEBUG] [e.transaction.ZigBeeTransactionQueue] - Broadcast: Set profile to ZigBeeTransactionProfile [maxOutstandingTransactions=3, interTransactionDelay=1200, maxRetries=0]
2019-12-21 13:42:13.078 [DEBUG] [e.transaction.ZigBeeTransactionQueue] - Multicast: Set profile to ZigBeeTransactionProfile [maxOutstandingTransactions=3, interTransactionDelay=1200, maxRetries=0]
2019-12-21 13:42:13.090 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Mesh Update Period 86400
2019-12-21 13:42:13.104 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - Adding supported cluster 1280
2019-12-21 13:42:13.120 [DEBUG] [com.zsmartsystems.zigbee.ZigBeeNode ] - ClusterMatcher starting
2019-12-21 13:42:13.122 [DEBUG] [com.zsmartsystems.zigbee.ZigBeeNode ] - ClusterMatcher adding cluster 1280
2019-12-21 13:42:13.126 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - Adding supported cluster 25
2019-12-21 13:42:13.128 [DEBUG] [com.zsmartsystems.zigbee.ZigBeeNode ] - ClusterMatcher adding cluster 25
2019-12-21 13:42:13.135 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - ZigBeeNetworkManager initialize: networkState=UNINITIALISED
2019-12-21 13:42:13.141 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - Network state is updated to INITIALISING
2019-12-21 13:42:13.146 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - null: networkStateUpdated called with state=INITIALISING
2019-12-21 13:42:13.213 [DEBUG] [ding.zigbee.internal.ZigBeeDataStore] - 000D6F0004BFEF51: ZigBee reading network state complete.
2019-12-21 13:42:13.216 [DEBUG] [atabase.ZigBeeNetworkDatabaseManager] - 000D6F0004BFEF51: Data store: Node was restored.
2019-12-21 13:42:13.221 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - 000D6F0004BFEF51: Updating node NWK=0
2019-12-21 13:42:13.240 [DEBUG] [ding.zigbee.internal.ZigBeeDataStore] - 7CB03EAA00B286F8: ZigBee reading network state complete.
2019-12-21 13:42:13.244 [DEBUG] [atabase.ZigBeeNetworkDatabaseManager] - 7CB03EAA00B286F8: Data store: Node was restored.
2019-12-21 13:42:13.251 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - 7CB03EAA00B286F8: Updating node NWK=32423
2019-12-21 13:42:13.278 [DEBUG] [ding.zigbee.internal.ZigBeeDataStore] - 00158D00044BB127: ZigBee reading network state complete.
2019-12-21 13:42:13.280 [DEBUG] [atabase.ZigBeeNetworkDatabaseManager] - 00158D00044BB127: Data store: Node was restored.
2019-12-21 13:42:13.282 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - 00158D00044BB127: Updating node NWK=58952
2019-12-21 13:42:13.298 [DEBUG] [ding.zigbee.internal.ZigBeeDataStore] - 00158D0002E91E33: ZigBee reading network state complete.
2019-12-21 13:42:13.311 [DEBUG] [atabase.ZigBeeNetworkDatabaseManager] - 00158D0002E91E33: Data store: Node was restored.
2019-12-21 13:42:13.315 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - 00158D0002E91E33: Updating node NWK=11590
2019-12-21 13:42:13.319 [DEBUG] [ngle.telegesis.ZigBeeDongleTelegesis] - Telegesis dongle initialize.
2019-12-21 13:42:13.323 [DEBUG] [ding.zigbee.handler.ZigBeeSerialPort] - Connecting to serial port [/dev/ttyUSB0] at 19200 baud, flow control FLOWCONTROL_OUT_NONE.
2019-12-21 13:42:13.400 [DEBUG] [ding.zigbee.handler.ZigBeeSerialPort] - Serial port [/dev/ttyUSB0] is initialized.
2019-12-21 13:42:13.415 [DEBUG] [gesis.internal.TelegesisFrameHandler] - TelegesisFrameHandler thread started
2019-12-21 13:42:13.424 [DEBUG] [gesis.internal.TelegesisFrameHandler] - TX Telegesis queue: 1
2019-12-21 13:42:13.428 [DEBUG] [gesis.internal.TelegesisFrameHandler] - TX Telegesis: TelegesisSetRegisterBitCommand [register=18, bit=4, state=true, password=null]
2019-12-21 13:42:13.436 [DEBUG] [gesis.internal.TelegesisFrameHandler] - TX Telegesis Data:ATS124=1

I did not notice this in advance… I guess I’ll have to get another dongle / coordinator. :frowning:

It will be a little further down - just a few more lines.

That’s correct, thank you!

2019-12-21 13:42:14.194 [DEBUG] [gesis.internal.TelegesisFrameHandler] - RX Telegesis: TelegesisDisplayProductIdentificationCommand [deviceName=ETRX357-LRS, firmwareRevision=308C, ieeeAddress=000D6F0004BFEF51, status=SUCCESS]

I probably will return it then, as it is not the correct revision.

1 Like

I guess they are selling some old stock - I’ve never come across an R308 version. R309 came out in 2015 and R308 is from 2012.

It should be possible to flash it with the Ember firmware, so if you’re in no hurry to get it working you might want to wait until @chris has some time to look for the firmware.

My smart plugs (which gave me trouble with the Telegesis) are working fine with the Ember.

If you don’t mind, are you able to provide a bit more of the startup log? I’d like to see where things start to fail so I could potentially improve the reporting…

Of course!
Right now I don’t have access to it, but I’ll upload it in 5 days when I’m back home.

1 Like

As promised, here is the complete startup log: openhab.log (420.3 KB)

The only thing I removed is the loading of my .rules-files. The log file is UTF-8, but my editor warned me about incompatible characters (probably at the end of the “SENDUCASTB” lines, so these might not correct).

Thank you. It looks like the firmware version is read here, so I will add a check during the startup to report the incompatibility - at least then it will be clear why it’s not working.

1 Like


@chris FYI, my Telegesis stick has firmware revision R309c. But, as mentioned, didn’t work with the Innr SP 120 smart plugs. Working fine with the EM3588-LR.

Here’s my ATI output:

Telegesis ETRX357-LRS