[Solved] Problem with knx 1.9 binding

Dunno if it’s due to my setup or a bug.

Setup: Raspi connected via USB to knx. eibd running on it and my OH1 lives on the same Pi. All good and running smoothly. (/usr/bin/eibd -d -D -S -T -i --pid-file=/var/run/eibd.pid usb:1:5:1:0:0) I use the same link for my Ets4 via IP.

Second Pi running OH2 and I try to use the OH1 Pi as KNX IP Gateway. (oh1 stopped during test)
I only get a connection to the knx bus via ROUTER:

//IP of my OH1 Pi with eibd
//TUNNEL does not work
// local ip makes no difference if localhost or external ip

Issue: Can’t read any item status and can’t write commands to the bus.
If I use a switch item - the openhab.log starts filling with log entries (item received command ON) and won’t stop until a restart of the knx bundle.

1.: For knx:localIp you have to set the ip from eth0, not lo (definitly!). Under some circumstances you should not set localIp at all.
2. For ROUTER Mode you must not set the knx:ip - or when, the ip would be something like (default IP for knx Routing) since ROUTER Mode uses Multicast (IP -
3. I’m not sure, if you can omit the knx:port for ROUTER Mode, especially if you are using eibd.

Thanks Udo

I’ve tried all thinkable permutations for both modes: TUNNEL and ROUTER.

In ROUTER mode I get only a theoretical connection… no bus events are ever sent or read.

So presumably this leaves me with the TUNNEL mode (which I use for OH1)

EDIT: Which finally works - I deleted OH2 and did a fresh install with the latest nightly… now it works.