[Solved] Problems with misc/exec.whitelist

Hello I get this error

Tried to execute 'php /home/openhabian/presence.php 60:AB:67:E9:5C:8B fritz.box:fritz.repeater', but it is not contained in whitelist.

/etc/openhab2/misc contains exec.whitelist

php /home/openhabian/presence.php 00:04:20:FD:FD:45 fritz.box:fritz.repeater
php /home/openhabian/presence.php 5C:A3:9D:08:AB:16 fritz.box:fritz.repeater
php /home/openhabian/presence.php 5C:F8:21:C9:9F:E7 fritz.box:fritz.repeater
php /home/openhabian/presence.php 60:AB:67:E9:5C:8B fritz.box:fritz.repeater
php /home/openhabian/presence.php 78:61:7C:FA:CA:90 fritz.box:fritz.repeater
php /home/openhabian/presence.php EC:10:7B:E1:B7:CB fritz.box:fritz.repeater
/usr/bin/ssh -p 10116 admin@**** halt

what is wrong??

I have the same problem without any solution… Did you solve the problem?


1 Like

I have managed to workaround this problem until 2.5.3(this problem is resolved now, but not released yet) will be released. Open crontab:

sudo crontab -e

Add the next command there:

@reboot $(sleep 120; echo >> /etc/openhab2/misc/exec.whitelist) &

This command will trigger appending a new-line to the whitelist file after 2mins after the system reboot.

1 Like

I don’t think this is solved in 2.5.3, please see my post: Exec.whitelist not used until edit/save after rebooting

It is. However it’s very apparent that there are a number of editors that don’t trigger the update process when saving changes. I advocate falling back to the version of the binding that doesn’t include the whitelist.


ExecStartPre=/bin/sleep 60
ExecStart=/usr/share/openhab2/runtime/bin/karaf ${OPENHAB_STARTMODE}
ExecStartPost=/bin/sleep 60
ExecStartPost=/bin/touch /etc/openhab2/misc/exec.whitelist
ExecStop=/usr/share/openhab2/runtime/bin/karaf stop