[SOLVED] Quite off topic but an odd network problem

I trust this category is ok for this. I’ve read many posts and there’s a lot of bright people out here. I’ve got a problem that I’ve (almost) run out of attempts to solve for. So if anyone is up for solving the mystery…

I upgraded from OH 2.0 to 2.3 using openhabian which didn’t go perfectly so I restarted with a fresh openhabian 2.3 and copied back my configs. Pretty much everything was back how it was.

Then I noticed, using the network binding and network ping that 3 cameras were offline. I switched them on but again later noticed they were offline. I ping the cameras and they didn’t respond. I then noticed lights on the cameras and sure enough I could http to their web interface and see video through the app. My Synology Surveillance Station has no problems with them. I went back to ping and no responses.

  • there are only 3 devices that cannot be pinged on my network by anything and they are all Dlink 935L cameras. Other devices (wired or wireless can be pinged) by all other clients.
  • they are all on 2.4gz WLAN and can be reached on their http 80 port no problems from any device browser.
  • when I ssh into the router I can ping other devices but no reply from these cameras.
  • it normally would feel like a firewall on the devices but I don’t believe the cameras have any (at the very least there is no configuration option for such things visible in their GUI)
  • they used to be pingable before the upgrade because I used that for notifications if they were down or disconnected or forgotten to be switched on.

I absolutely don’t believe it has anything to do with openhab (on rpi 3B). There may have been some setting I changed on my dd-wrt router but I’ve been back over the whole config and can’t see anything untoward, at least not something that would just affect these 3 devices.

I’m not sure what other diagnostic steps to perform. I know I can use the network binding service ping to achieve the same thing but I like to get to the bottom of this. I’ve never come across a device on the same LAN that couldn’t be pinged (and when it couldn’t it was a firewall issue on the client I was using). Here I’ve tried Win7, Win 10, Mac, iphone, tablet, the rpi, even sshing to the router itself and pinging from there.

Any network or config gurus willing to suggest anything?

They may not respond to normal ping, but you may have previously set up arping and it was able to use this to detect their presence on the network.

After many days of various diagnoses and getting to the point of posting here I stumbled to the camera firmware release notes and there is one line where ICMP ping was disabled (as a security measure).

I do have that firmware but I didn’t upgrade that since whenever. It’s the best fit but not sure how. I’m surprised I couldn’t find more on the web about this change and its impact.

Anyway now using network service binding instead and closing the mystery.

1 Like