[SOLVED] Raspberry Pi 3 and latest OpenHABian

  • Platform information:
    • Hardware: Raspberry Pi 3
    • OS: OpenHABian

I just installed the latest OpenHABian from here:

Extracted it and istalled it on a fresh formatted SD card on my Win7 PC.
I inserted it into the Raspberry and booted up.

After long waiting and no response on the IP adress, I connected via SSH and checked whats wrong.

I saw an Error:
Installing Zulu Embedded OpenJDK… FAILED

I tried to reinstall using the openhabian-config but it also got stuck (cant remember the exact message)…

So I formatted the SD card again and flashed OpenHABian again.

This time with 100% like here descriped:

waited a bit…
nothing happend…
connected again via putty:
2018-03-13_22:54:30_UTC [openHABian] Updating repositories and upgrading installed packages… FAILED

How many tries do you need to get it installed once and whats the problem of this?

I already tried to install it manually before (on latest raspbian stretch)…
there i was at least able to install openhab - but it gets stuck after trying to install the “Standard” package via the browser…

any hints are appreciated

Hm … Installed a fresh openhabian on Pi 2 last Friday.
Runs fine.
Guess it’s your microSD card, which might be broken or your internet connection isn’t stable, as both errors occures during installing packages from the internet.
Maybe i’m wrong, but better check this first.

I also installed a fresh copy of openhabian on rpi3 b+ the other day for the first time

i used etcher to burn my image don’t forget too wait for 45 mins during install

I retried it again… this time it works.

Nothing changed at this try.

Same Wifi, same microSD (new Samsung Evo Plus with 94MB/s read/ 37MB/s write), same Samsung 5V 2A power supply (its used for month for Pi3 and Pi3B+).

Last message on putty: Waiting for openHAB to become ready…
Needed about 10min

Then fire up my Fox and browsed to the IP, chose “Standard” then “Log Viewer”.
11:35:04.270 [thome.event.ExtensionEvent] - Extension ‘ui-paper’ has been installed.

its now 20min after inserting the SD card… so it seems to work finally.
I have no idea what caused the 2 (!) failed attempts… same procedure like the 2nd try.

Anyways: Thanks guys!

1 Like