[SOLVED] Raspberry PI4, OpenHabian, Aeotec Z‐Stick Gen5 USB Controller

  • Platform information:

    • Hardware: Raspberry Pi 4 Model B, 2GB
    • OS: openhabian
    • openHAB version: openhabian-pi-raspbian-201908050414
  • Issue of the topic: Z-Wave Serial Controller is offline. I saw the Z-Stick once with lsusb, but it disappeared after restart. There is no change (lsusb or dmesg -w) when I insert or remove it. I tried a fresh installation, but the result was the same.

Z-stick is ok. I tried it in Windows OpenHab installation.
USB port ok. The USB drive is operating normally.

Any idea what’s wrong?

  • Console command output:
    [20:52:02] openhabian@openhab:~$ lsusb
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

[20:52:42] openhabian@openhab:~$ ls -l /dev/ttyA*
crw-rw---- 1 root dialout 204, 64 Sep 12 20:44 /dev/ttyAMA0

[20:55:42] openhabian@openhab:~$ cat /etc/group | grep dialout

If you had searched for RPi4 and Aeotec here or on the Inet you would have found information about electrical issues with that combination. Guess you have to change HW.

1 Like

Thanks for notifying me of the HW problem. I was looking for a problem in the OS. The solution was brought to me by an old USB HUB. The Z-Stick connected via it works well.