[SOLVED] Rebuilding after disaster

  • Platform information:
    • Hardware: Raspberry Pi 3 Model B Rev 1.2
    • OS: Raspbian GNU/Linux 10 (buster)
    • Java Runtime Environment:
    • openHAB version: openHAB 2.4.0-1 (Release Build)

I’ve had a bit of a disaster, which has resulting in me having to rebuild my openhab2 installation from scratch. I had a backup of my things, items, rules and sitemap so after installing the latest version I just copied these back to the relevant folders.

However noting seems to work, I can select a item on the site map, but the corresponding device does not work. Example a wemo switch controlling a lamp.

The switch is defined in the things file as

wemo:socket:Lamp_Switch              [udn="Socket-1_0-221544K11003A8"]

in the items file as

Switch LivingroomLamp "Livingroom Lamp" (Lights) ["Switchable"] {channel="wemo:socket:Lamp_Switch:state"}

I get this message in the logs

2019-10-29 12:24:11.339 [INFO ] [rest.core.internal.item.ItemResource] - Received HTTP POST request at 'items/LivingroomLamp' for the unknown item 'LivingroomLamp'.

Do I need to re-write my items files in some way?

Are the Item links the same?

For instance, is udn="Socket-1_0-221544K11003A8 the correct ID for that Wemo device?

Yes it is, this is a discovery result from UPnP discovery.

@GrahamH, please check your openHAB log if it states an issue with your items file.
The error indicates that the item cannot be found for some reason.

1 Like

Filtering on ‘LivingroomLamp’ I can see these additional log entries

2019-10-29 11:55:57.118 [ERROR] [ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item 'LivingroomLamp' for widget org.eclipse.smarthome.model.sitemap.Switch

2019-10-29 11:56:15.148 [WARN ] [basic.internal.render.SwitchRenderer] - Cannot determine item type of 'LivingroomLamp'

org.eclipse.smarthome.core.items.ItemNotFoundException: Item 'LivingroomLamp' could not be found in the item registry

Please open your items file, add a space at the end and write it back.

1 Like

That kind of worked, it logged a warning

Configuration model 'myhome.items' has errors, therefore ignoring it: [69,85]: missing ')'

Added the closing bracket and things seem to be working now.
Cheers guys.


Please mark this thread as solved.

1 Like