[SOLVED] Remote Access is slow

I just thought that it’s because the iOS app is kind of old and may not fully support iOS12… Others reported that as well. But if it happens on Android as well, then it might be some other problem.

YES I have also bad performance (at work, at home, also via mobile provider) with myopenhab via chrome and other browsers.

Interesting. Myopenhab from browser seems a little slower than usual for me, but it is usable. The iOS app is almost unusable, it just displays a request timed out error…

Connecting remotely with the OpenHAB Android App is extremely slow. When I connect locally it is very fast.

@digitaldan Can you have a look at this issue? There are also play store reviews mentioning a slow connection.

I’ll take a look, I have on my todo list to add another server to our system to help with load.


I have the same problem. Thank you very much for your work.

Also have same issue from yesterday evening, it comes with soket error in logs. Local ip address connection works like a charm, remote Android app and myopenhab slow as hell…

Same problems here. Can’t access my dashboard from myopenhab and neither remotely from the openhab app. Also IFTTT integration doesn’t work.

Local Openhab connection still works perfectly.

I have also the same problem.
But over the website I reach my dashboard.

I believe it is related either to the app, or to the server-side app API. Web interface works pretty fast. I am having issues since last update on my Xiaomi Mi Mix 2s with Android 9. It takes 5 minutes just to load my home page in the app.

Same here after updating the app to 2.4 running on Samsung S8 (Oreo).

I gave up trying to connect to external today. Local seems to work fine and fast. I updated the openhab app yesterday.

Same here. The last weeks it was very slow and today even slower or not working for hours.
Only remote (wifi and data) with android app. myopenhab working

Same here, the remote connection is extremely low.

Please someone advise about the main reason.

Same here, app on ios timeout and is not usable at all. Sometimes it loads my sitemap and fail after when browsing other tabs. Local access is working.

Throwing my hat in the ring… I have also have been having very slow remote connections via OH cloud connector - both from the Android app and from the a PC, but access from the Android app is far worse. I estimate I’ve been having the issue for about a week if my memory serves correctly. Echo and Google Home have also had sporadic issues in the same time period communicating with OH. I’ll have to set up remote access manually (the old fashioned way w/o cloud connector) while this gets figured out.

If this helps anyone smarter than me, I recorded a session below from a PC. The recording started upon clicking Basic UI after locking into myopenhab. This is actually one of the faster load times. The tool reported slow connection most of the time.

Same here.

I have tested 4 of my OpenHAB connections from 3 parts of the UK (Devon, Manchester, Yorkshire).

Tested 2.4.0 Milestone, 2.3.0 & 2.2.0

Sometimes works through the browser (Chrome) but sometimes it takes forever to log on or I get a 504 error.

iOS App very temperamental - Remotely works about 2 out of 10 times but works perfectly when local.

I have also noticed that sometimes my cloud connection goes off altogether and I have to restart my Pi3.

All my openHAB instances worked perfectly about a month ago. I have not touched 3 of them at all. I have started one from scratch and even delete my cloud account and connection but the problem still persists.

I can confirm this as well, I cannot access remotely through openhab.org from my android and iOS phones.

I can access through a PC browser but it is very slow.

Same here, even in local with custom https port