[SOLVED] Remote Access is slow

Dan fixed it :slight_smile:

It’s working very fast now for me!

Thanks for the feedback. There is still a lag issue for sure which I am looking into to, Most likely this will require additional infrastructure and some changes to our front end load balancer to accommodate. This is the next thing on my list to tackle.

1 Like

My colleague and I both use the Openhab Android app. At the same time, the app (Remote Access) is very fast with him and is totally slow with me. We both have an openhab2 2.3 installation.

Sorry, but i can not share LSpaula’s oppinion. it is completely unusable!
The IOS App get’s timeouts and does not Show anything.

why is the way over the Website so fast?
there must be the same Servers or not ?


It was usable yesterday. It is unstable right now. Dan has given us the reason. Let us allow him to figure it out the required changes to the infrastructure. Awesome support, by the way. Thank you very much for that, Dan.

The mobile apps have two differences from using the browser, the first is they use basic http authentication, your browser usually uses cookie based auth token. Second is that the mobile apps do not use cookies in their request which, if available, the cloud services uses to look up cashed data to speed things up.

There is definitely a load issues around authentication OR how we look up and route the request to the right server that has the openHAB socket connection based on that cookie not being there.

I’m looking at this now to determine which part is the issue and how we fix this. I am also planning on looking at adding cookie support to the mobile clients, although that is secondary to fixing the core issue.


Thank you Dan for Information and your time & work!
I will be patient until you have new information. :wink:

FYi this looks like its not a Basic Auth issue but we are handling internal requests between Ngnix and nodejs when there is no cookie in the request header. Still looking.

1 Like

Ok following this string hoping the solved tag

Webhooks with cmd do not work too

You should not rely on those webhooks, as they are not officially supported and might stop working one day without further notice.
You should go the REST path.

Good morning everyone,

the maintainance of the MyOpenHAB-BackEnd has ended.
DigitalDan was working on our Problem.

But the connect of IOS-App is still not possible.
So there will be further things to do…

We have to be patient…


Connecting with Android App is still not possible for me.

Thank you for working at the problem. At the moment myopenhab.org is not working.

I can confirm:
Via Browser myopenhab.org fails when i click You are using openHAB 2.x. [Click here to access your openHAB’s dashboard]
SSL failure

App: same. SSL Handshake failed

Edit: Online and fast!

The problems for me are gone, a fast android app again. ( fast connection to myopenhab.org).

Anyone else experiencing the same?

For me too, now it works very fast, also the iOS app. Big thanks for the hard work!

for me it works fast and smooth too.
Many Thanks to all supporters!!!

the problem persists.

Android App:
SSL handshake failed

unexpected end of stream on
Connection{myopenhab.org:443, proxy=DIRECT@
6_GCM_SHA384 protocol=http/1.1}

any solution?

The Problems for me are gone. Many Thanks to openhab Team.